Log in or register to post comments

RendererApiNotSupportedException: The renderer API OpenGLCore is not supported. Video background rendering is not possible.

April 29, 2019 - 9:24am #1

I'm facing this issue since I installed Unity 2018.3.14f1

I tried to update Vuforia to 8.1.10 and still having this issue.

The Error: RendererApiNotSupportedException: The renderer API OpenGLCore is not supported. Video background rendering is not possible.

My config:

MacBook Pro with MACOS Mojave.

Could you help me guys?

Thanks

RendererApiNotSupportedException: The renderer API OpenGLCore is not supported. Video background rendering is not possible.

May 20, 2019 - 8:06pm #5

Our team is working on a fix

Setting the API to Metal should fix it.
We don't support Mac standalone, so the setting shouldn't matter

RendererApiNotSupportedException: The renderer API OpenGLCore is not supported. Video background rendering is not possible.

May 17, 2019 - 10:47am #4

Vuforia employee here - I'm seeing this same error with the same setup (Mojave, Unity 2018.14.1f1, Vuforia 8.1.1) - I've raised the issue with our engineering team and will get back to you when i get an answer

RendererApiNotSupportedException: The renderer API OpenGLCore is not supported. Video background rendering is not possible.

May 9, 2019 - 12:26am #3

I also have the same problem and found a temporary solution by adding the below line in the Awake() function 

VuforiaRenderer.Instance.SetLegacyRenderingEnabledCondition(() => true);

from this link https://developer.vuforia.com/forum/unity/setlegacyrenderingenabledcondition

But I think this is a temporary solution and the Vuforia team should come up with a permanent solution for this problem.

 

 

RendererApiNotSupportedException: The renderer API OpenGLCore is not supported. Video background rendering is not possible.

May 7, 2019 - 3:19pm #2

Any luck vrjoy? i've got the same issue and spent two days trying to find a solution but nothing seems to be working :/

 

Log in or register to post comments