Log in or register to post comments

Sharing violation exception when trying to import

April 28, 2019 - 7:03am #1

I've got several problems after installing the new updated version 8.1.1 of vuforia.

one of them is

"IOException: Sharing violation on path"

when trying to import a new component through:

GameObject >> Vuforia Engine >> ARCamera(or any other package from the list).



I believe that i can resolve most issues by re-importing the packages, but Vuforia doesn't allow me to do so.

one big disappointment, Vuforia..



I need one of the following to resolve my problem:

A. Link to an older version of Vuforia(one before the 8.1.1) where everything worked fine.

B. Work-around for re-importing the components in GameObject >> Vuforia Engine

C. Link to missing script files for 'ICloudRecoEventHandler', and DefaultTrackableEventHandler. from the last version v8.1.1

[EDITED]

I solved my problem with option A. found the previous version 8.0.1 on one of my other computers.

Follow this link, to download it, if you want. unpack the "Vuforia Support" folder into Unity\Editor\Data\PlaybackEngines\

after deleting the previous "Vuforia support" folder.

 

I'll notify you if i find any solution.

currently my project is broken.



P.S. There are alternatives to Vuforia AR Engine, keep that in mind.

 

AttachmentSize
Image icon VuforiaIssue8.1.1.jpg63.16 KB
Log in or register to post comments