Topic locked

[SOLVED]Known Issue: Installing Vuforia Engine on Unity 2020.3.2 or 2021.1.1

April 7, 2021 - 8:48am #1

Hello, 

Installing Vuforia Engine on Unity 2020.3.2 LTS and 2021.1.1 results in following error: 

An error occurred while resolving packages:

  Project has invalid dependencies:

    com.ptc.vuforia.engine: Error when executing git command. fatal: update_ref failed for ref 'HEAD': cannot update ref 'refs/heads/master': trying to write non-commit object 2aa4b218a1eefc116d8bef718e26f3a08d2e5f02 to branch 'refs/heads/master'

A re-import of the project may be required to fix the issue or a manual modification of /Users/mcotora/UnityProjects/CS98TestUnityLTS/Packages/manifest.json file.

 

We propose following workarounds:

1. Download the SDK and import it manually, steps from where and how are available here: https://library.vuforia.com/articles/Solution/vuforia-engine-package-hosting-for-unity.html. Please note, Mac-users have an additional step that needs to be performed, as MacOS will try to quarantine the package.

2. Use a previous Unity version such as 2020.3.1

We are in contact with Unity and are investigating the issue.

Issue has been solved.

Thank you.

Vuforia Engine Support

[SOLVED]Known Issue: Installing Vuforia Engine on Unity 2020.3.2 or 2021.1.1

May 10, 2021 - 12:39am #3

HI @nurfartinah,

Yes, it was fixed. If this does not work, please use the workaround mentioned here:

 Download the SDK and import it manually, steps from where and how are available here: https://library.vuforia.com/articles/Solution/vuforia-engine-package-hosting-for-unity.html. Please note, Mac-users have an additional step that needs to be performed, as MacOS will try to quarantine the package.

I will lock this thread, if you still have issue, please create a separate thread.

Thank you for your understanding.

Vuforia Engine Support

[SOLVED]Known Issue: Installing Vuforia Engine on Unity 2020.3.2 or 2021.1.1

May 7, 2021 - 7:58am #2

Are you sure this problem already solved ? Been doing & get the same error for weeks. The git for vuforia doesnt support on unity i cant even iMport vuforia properly.

Topic locked