Log in or register to post comments

Stop specific image targe scan

August 27, 2018 - 5:18am #1

I have an application on unity and vuforia. The application contains a vumark with several different codes and several target images. When the application starts, it must scan the vumark first, and vumark activates the image target that can be scanned.

The problem is that you only have one option to pause all scams with | TrackerManager.Instance.GetTracker <ObjectTracker> (). Stop () ;.

I need to pause only one image target and the vumark. Something like imageTarget.StopScanThisSpecificImage ();

Have anything like this, or for pause only vumarks scan?

This seems to be affecting the performace of the app

Stop specific image targe scan

August 29, 2018 - 11:19am #6

how a i do this?

Stop specific image targe scan

August 29, 2018 - 10:43am #5

Hello,

My recommendation would be to disable the Vumark dataset when you no longer want to be able to detect it.

Thanks,

Vuforia Engine Support

Stop specific image targe scan

August 29, 2018 - 6:37am #4

Tanks for answer, 

I solve my problem disable and enable the image target behaviour, a component inside image target`s, but with vumarks this doesn't work, even disabling all components or the gameobject, vumark aways is enable. 

have a only way to disable only vumark? 

Stop specific image targe scan

August 28, 2018 - 5:12pm #3

Hello alandlb92,

There are two different ways to do this that I can think of off the top of my head.

The first would be to disable the Image Target game object until you are ready to scan it. You can do this by setting the Unity object that represents this target to be active = false. This will stop that object from functioning in the scene.

The other way to do this would be to have that Image Target in a dataset by itself and then you can enable or disable the dataset with code when you want to toggle whether or not you can detect it.

The same can be done with your Vumark.

Thanks,

Vuforia Engine Support

Stop specific image targe scan

August 27, 2018 - 6:41am #2

I have the same problem

Log in or register to post comments