Log in or register to post comments

Text Recognition in Vuforia 6.2.9

January 15, 2018 - 2:07am #1

I know, that Text Recognition is now deprecated with Vuforia 7.

But anyway it is wonderful feature that can help me a lot.

 

I am using integrated version of Vuforia 6.2.9, Unity 2017.2.0p1. And I would like to use Text Recognition.

 

So I downloaded legacy Unity Extension package 6.2.10 from https://developer.vuforia.com/vui/auth/login?url=/downloads/sdk%3Fd%3Dwindows-30-16-4815%26retU.

And I imported that package to my project. It also contains suitable prefabs for Text Recognition like TextRecognition and Word prefab.

But after impoting that package to my project I get this error:

error CS1704: An assembly with the same name `Vuforia.UnityExtensions' has already been imported. Consider removing one of the references or sign the assembly

C:/Program Files/Unity/Editor/Data/PlaybackEngines/VuforiaSupport/Managed/Runtime/Vuforia.UnityExtensions.dll (Location of the symbol related to previous error)

Assets/Vuforia/Scripts/Internal/Vuforia.UnityExtensions.dll (Location of the symbol related to previous error)

 

I undarstand, that problem is in using in using Vuforia twice, specially Vuforia.UnityExtensions.dll.

Therefore I deleted Vuforia.UnityExtensions.dll from Assets\Vuforia\Scripts\Internal. But than I get error like:

"The type or namespace name TextRecoAbstractBehaviour, BackgroundPlaneAbstractBehaviour and other could not be found."

 

It looks like TextRecoAbstractBehaviour, BackgroundPlaneAbstractBehaviour and other types are only in Assets\Vuforia\Scripts\Internal\Vuforia.UnityExtensions.dll (legacy package), not in C:\Program Files\Unity\Editor\Data\PlaybackEngines\VuforiaSupport\Managed\Android\Vuforia.UnityExtensions.dll, which is integrated with unity.

 

Can someone help me how to solve this problem?

Or is there any other way, how can I perform text recognition in Vuforia 6.2.9, Unity 2017.2.0p1?

 

Text Recognition in Vuforia 6.2.9

April 7, 2020 - 4:32am #3

hello

Text Recognition in Vuforia 6.2.9

January 15, 2018 - 8:46am #2

Hello vladinko0,

Vuforia 6.2.X is not compatible with Unity 2017.2. You'll need to use Unity 5.6 if you plan on using this version of Vuforia. Keep in mind, the natively integrated Vuforia 6.5 that comes with Unity 2017.2 still has the Text Recognition feature. The premade objects are unavailable, but you can still set the feature up by adding the necessary scripts to an object.

Thanks,

Vuforia Support

Log in or register to post comments