Topic has a solution and is locked
Topic locked

Unable to install Vuphoria

November 4, 2021 - 12:16am #1
Topic solved

I received this error:

Library\PackageCache\com.ptc.vuforia.engine@d6bb25eb462d-1632536114000\Vuforia\Editor\Scripts\OpenSourceInitializer.cs(29,27): error CS0012: The type 'Editor' is defined in an assembly that is not referenced. You must add a reference to assembly 'UnityEditor.CoreModule, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.

and warning:

Library\PackageCache\com.ptc.vuforia.engine@d6bb25eb462d-1632536114000\Vuforia\Editor\Scripts\DefaultTrackableEventHandlerEditor.cs(14,26): warning CS0618: 'DefaultTrackableEventHandler' is obsolete: 'DefaultTrackableEventHandler is obsolete and will be removed soon. Please use DefaultObserverEventHandler instead'

 

Please help! I have no idea what is going on and how to fix it.

Unable to install Vuphoria

January 1, 2022 - 6:23pm #6

same Error :( how to fix this?

Unable to install Vuphoria

November 11, 2021 - 7:22am #5

Hey there,

 

The minimum Unity version was increased from 2019.x to 2020.x for Vuforia Engine 10.0 and higher. I'd recommend upgrading to a newer version of Unity before importing Vuforia Engine 10.x. If the errors persist with a new project I recommend creating a new forum thread.

 

Kind regards,

Patrick Scheper

Technical Community Manager

Unable to install Vuphoria

November 9, 2021 - 10:22pm #4

Experiencing the same issue with Unity 2019.4.32f1 and Vuforia 10.2.5.

Library\PackageCache\com.ptc.vuforia.engine@d88780381e17-1632536113000\Vuforia\Editor\Scripts\OpenSourceInitializer.cs(29,27): error CS0012: The type 'Editor' is defined in an assembly that is not referenced. You must add a reference to assembly 'UnityEditor.CoreModule, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.

Unable to install Vuphoria

November 9, 2021 - 8:33am #3

Probably a version mismatch issue. I had the exact same error when I tried importing Vuforia 10.2 into a Unity 2019.4 project. The error was fixed when I upgraded the project to Unity 2020.3.

Unable to install Vuphoria

November 5, 2021 - 9:30am #2

Hello,

Which version of Engine SDK are you trying to install? And using which Unity version?

Thanks,

Vuforia Engine Support

Topic locked