Log in or register to post comments

Unity 2017.2 + Vuforia Eyewear support

October 13, 2017 - 3:00am #1

Just upgraded to Unity 2017.2 and using the integrated Vuforia objects, but it doesn't seem like Eyewear is supported, even though the menu options are still there? Any further information on this or how i could fix it?

When i try using it with Video See-Through - Generic Cardboard, i just get a black screen, and when my target gets detected, the rendered objects show up over the black background. There's also no stereoscopy / split video for each eye.

I don't really want to downgrade my versions of Unity/Vuforia, because i think that'll also mean i need to downgrade my iOS.

Unity 2017.2 + Vuforia Eyewear support

October 13, 2017 - 3:14am #2

solved the issue. in the Player Settings (and under XR Settings) you need both VR and AR checked (which they both get checked when you select VR), and click the plus sign to add Vuforia SDK.

 

Will this change in the future? It seems like I would only check AR if i needed Cardboard style rendering, but apparently VR needs to be checked as well.

 

Cheers

Log in or register to post comments