Log in or register to post comments

unity compiler error

July 4, 2018 - 7:47am #1

dears 

 

i have been trying with unity to create an AR scene using image and fbx file , i keep having the below error

 

assets/common/scripts/trackablesetting.cs: error cs0246: the type or namespace name  "fusion provider type" could not be found, are you missing an assembly reference?

 

could any one help me in this matter.

unity compiler error

October 23, 2018 - 8:50am #7

Reported in June, yet still happening now for me. Did you get it working?

unity compiler error

July 26, 2018 - 11:48am #6

Hello all! I tried the Core and GroundPlane examples with latest version of Unity and have the same problem...

unity compiler error

July 12, 2018 - 10:39pm #5

I have same problem, but now I solve it.

Click folders sequentially In Unity, Assets -> Resources -> VuforiaConfiguration(or mac user, command+shift+v)

Then you can check Vuforia Version. If the version is not latest, then click hyperlink for updating version.

Restart your project & reimport your project's assets.

unity compiler error

July 6, 2018 - 10:11am #4

What version of Unity and Vuforia are you using? If you've updated to the latest samples in 2018.1, you'll need to update your Vuforia in the Vuforia Config file to 7.2.20 or you'll face this issue.

Thanks,

Vuforia Engine Support

unity compiler error

July 5, 2018 - 9:52pm #3

MOHAMEDSAEED121 wrote:

could any one help me in this matter.

You can try to create C#-script "FusionProviderType.cs" with code:

public enum FusionProviderType

{

    INVALID_OPERATION = -1,

    VUFORIA_VISION_ONLY = 1,

    VUFORIA_SENSOR_FUSION = 2,

    PLATFORM_SENSOR_FUSION = 4,

    ALL,

    OPTIMIZE_IMAGE_TARGETS_AND_VUMARKS,

    OPTIMIZE_MODEL_TARGETS_AND_SMART_TERRAIN = ALL

}

It might be helpful but almost all .cs files have bugs so prepare for new issues. But this one is resolved I think.

unity compiler error

July 5, 2018 - 9:32pm #2

Yep, same problem. :/

I've just downloaded "Vuforia Ground Plane" package and I have same issue. To resolve this problem, I've tried to find (in list of files of importing UnityPackage) any file with name "FusionProviderType". But nope: there's no such file. 

Even here:

https://assetstore.unity.com/packages/templates/packs/vuforia-ground-plane-107216

there're people with same problem in comments. 

Please, Vuforia, repair this!

Log in or register to post comments