Log in or register to post comments

Unity UWP Build - Low Quality Camera Feed

April 3, 2019 - 12:33pm #1

Despite my device having a 1080p camera feed, I always seem to get a low quality camera feed. Even when i set the enum to optimize_quality. Is there any other way to squeeze the full output of the camera? 

Unity UWP Build - Low Quality Camera Feed

April 19, 2019 - 2:10pm #9

Hello @aircordinc,

Vuforia Engine SDK does not commercially support desktop PCs. Thus, we have no recommendation for how to make this adjustment.

Thanks,

Vuforia Engine Support

Unity UWP Build - Low Quality Camera Feed

April 18, 2019 - 7:11pm #8

The issue is only in the UWP build, as in playmode it displays in 1080p.

The device we are using it on is a desktop PC.

We have tried MODE_OPTIMIZE_QUALITY, as well as MODE_OPTIMIZE_SPEED and MODE_DEFAULT, but all three result in the resolution staying at 720p upon build. 

Unity UWP Build - Low Quality Camera Feed

April 18, 2019 - 2:02pm #7

In the UWP Build. 

Unity UWP Build - Low Quality Camera Feed

April 18, 2019 - 11:08am #6

Hello @aircordinc,

aircordinc wrote:

In the Unity editor PlayMode the resolution is 1080p, but after UWP build the resolution goes down to 720p. Are there any known fixes for this?

Supported PlayMode camera resolutions (dependent upon your web cam capabilities) will not always match those supported by a device. Devices have different capabilities based upon their software and hardware profiles.

If you're looking for higher resolution experiences in the UWP build (aka on device), try selecting Camera Device Mode = MODE_OPTIMIZE_QUALITY in Unity Editor->Window->Vuforia Configuration. However, note that the resolutions mapped to different camera device modes may vary for different device models.

Thanks,

Vuforia Engine Support

Unity UWP Build - Low Quality Camera Feed

April 17, 2019 - 10:21pm #5

Hello,

Has this issue been solved? I am facing the same issue with the same setup, using logitech c920 webcam and vuforia 8.0.

In the Unity editor PlayMode the resolution is 1080p, but after UWP build the resolution goes down to 720p. Are there any known fixes for this?

Unity UWP Build - Low Quality Camera Feed

April 5, 2019 - 2:27pm #4

Hello,

Thanks. Is this in PlayMode? Or have you gotten Vuforia Engine to run in a standalone config?

-Vuforia Engine Support

Unity UWP Build - Low Quality Camera Feed

April 5, 2019 - 11:10am #3

Logitech C920 Webcam using vuforia 8,0

Unity UWP Build - Low Quality Camera Feed

April 5, 2019 - 9:13am #2

Hello,

This really depends upon the device. Many devices struggle to sustain 30 fps rate while tracking at 1080p.

Vuforia controls the camera capture frame rate and resolution. Some devices have explicitly defined performance sets (via a "device profile"), and some are created programatically upon SDK start.

What device are you using?

Thanks,

Vuforia Engine Support

Log in or register to post comments