Log in or register to post comments

Upgrading to 7.2.20 in Unity

July 20, 2018 - 1:26am #1

I used the "Upgrade to Vuforia 7.2.20" link in the Unity Inspector.

However, following this I cannot build in Xcode 9.4.1

dyld: Library not loaded: @rpath/Vuforia.framework/Vuforia

  Referenced from: /var/containers/Bundle/Application/9559D029-BCB9-4128-80F7-60E5301D3F3A/lakarhuset.app/lakarhuset

  Reason: no suitable image found.  Did find:

/private/var/containers/Bundle/Application/9559D029-BCB9-4128-80F7-60E5301D3F3A/lakarhuset.app/Frameworks/Vuforia.framework/Vuforia: code signing blocked mmap() of '/private/var/containers/Bundle/Application/9559D029-BCB9-4128-80F7-60E5301D3F3A/lakarhuset.app/Frameworks/Vuforia.framework/Vuforia'

(lldb)

Upgrading to 7.2.20 in Unity

July 24, 2018 - 11:30am #12

Hello,

Really happy to hear this was resolved for you. Thanks for posting the fix here!

-Vuforia Engine Support

Upgrading to 7.2.20 in Unity

July 24, 2018 - 5:46am #11

IT IS SOLVED

 

the fix is described here. It has do with a major Xcode bug

https://stackoverflow.com/questions/24993752/os-x-framework-library-not-loaded-image-not-found/41401354#41401354

Upgrading to 7.2.20 in Unity

July 24, 2018 - 5:40am #10

I tried new 7.2.23 version of Vuforia but it had the same issues.

Upgrading to 7.2.20 in Unity

July 24, 2018 - 1:08am #9

Thank you!

 

I am using version 2018.1.6f1

Upgrading to 7.2.20 in Unity

July 23, 2018 - 5:44pm #8

Hello,

OK we'll take a closer look into the issue.

Which version of the Unity Editor are you running?

Thanks,

Vuforia Engine Support

Upgrading to 7.2.20 in Unity

July 23, 2018 - 1:51pm #7

@VuforiaTeam please get one of your proficient xcode/ios developers to look at this. I have run out of options

Upgrading to 7.2.20 in Unity

July 22, 2018 - 2:28pm #6

Anyone got this working? Are you using auto-signing in xcode?

Upgrading to 7.2.20 in Unity

July 20, 2018 - 3:04pm #5

I am quite certain this has to do with the new code signing of the Vuforia Framework, that occurs at Build. However, no idea what the fix is

Upgrading to 7.2.20 in Unity

July 20, 2018 - 3:01pm #4

1. Yes, I tried building the samples. The issue exists there as well.

2. I reviewed the issue you linked to, but it did not work. I believe it has nothing to do with this problem.

 

I need help please!

Upgrading to 7.2.20 in Unity

July 20, 2018 - 11:00am #3

Hello,

Have you tried building the samples to see if the issue exists there, as well?

If so, be aware that there are compatibility issues between the previous Vuforia samples (before 7.2) and the current ones. So, since you've upgraded to 7.2.20 SDK, you should reimport the samples, too.

Lastly, consider reviewing this issue, as well: https://developer.vuforia.com/forum/unity/vuforia-7220-ios-submission

Thanks,

Vuforia Engine Support

Upgrading to 7.2.20 in Unity

July 20, 2018 - 6:09am #2

I tried xCode 10.0 beta 4 and it's still broken

Log in or register to post comments