Log in or register to post comments

User Defined Target Unity 2017.2

October 12, 2017 - 12:22am #1

Hi all, I started using Vuforia for a few days and I am trying to understand the operation well.

I have a problem with the detection of a particular image: It is an invoice (then text document). I tried first of all to upload the image in the Vuforia database but the rating was 0 out of 5, following the guidelines I managed to take it to 1 star out of 5. I can in no way change the content or colors of the image as the customer needs it as it is. So I thought I'd try with the User Defined Target (I hope it's the best way to do that) but the guides I found are with Vuforia 6.2.6 (old). I currently use Unity 2017.1 with Vuforia 6.2.10 (for the User Defined Target has undergone some modification) or I tried Unity 2017.3 with integrated Vuforia but there seems to be no option.

Now I ask you:

-Is there a way to use the image with 1 star in an optimal way?

-If with the User Defined Target, where can I find some material that explains how to use it on unity 2017.2 or 2017.3 or on Vuforia 6.2.10?

-Could I otherwise set reference points on the image manually?

Thanks in advance for any advice and solutions.

Manuel.

User Defined Target Unity 2017.2

October 12, 2017 - 10:42am #4

Hello Trese992,

I'm glad you were able to resolve your issue. To provide some more information overall on this, 2017.1 is not a supported version of Vuforia and we recommend going with 2017.2 going forward.

Overall, a 1 star image will have detection and tracking issues. Good lighting and camera focus can help with this, but you'll need ideal conditions to ensure this tracks. UDT uses the same type of tracking as Image Targets, so you will likely run into the same issues here.

Thanks,

-Vuforia Support

User Defined Target Unity 2017.2

October 12, 2017 - 6:37am #3

Solved by upgrading Unity version to 2017.2.0b11.

User Defined Target Unity 2017.2

October 12, 2017 - 6:07am #2

Solve by change Unity version on 2017.2 and download the Vufiora Core from assets store. There is another problem:

I load the sample scene 3 - UserDefinedTarget and i try to debug in on unity and on device (android) with default settigs. The problem is the background camera is ever black, don't see the ambient in front of camera but the application, with the black screen, see the image and render the 3D object on it. I can see only the 3D object.

How can i solve this?

AttachmentSize
Image icon Screenshot_2017-10-12-15-06-25[1].png97.98 KB
Log in or register to post comments