Log in or register to post comments

Using older versions of Vuforia with newer versions of Unity

July 17, 2020 - 3:48am #1

Hello! A project I am currently working on requires the use of the front camera, but it seems that the feature was deprecated and removed in Vuforia v8.2. However, I was wondering if it is possible to use older versions of Vuforia (Like v7.5) with Unity 2019.4. From my understanding, the way Unity and Vuforia interacted with one another since then have changed drastically, but is there anyway to reconfigure or export the files from the older version of Vuforia and import them to work with Unity 2019.4?

Using older versions of Vuforia with newer versions of Unity

February 15, 2021 - 1:35am #6

Hi,

Unfortunately the setup is not supported.

We support VE 9.x on 2019.4 and also there where some braking changes introduced in iOS14 which brakes the features from Vuforia Engine which use Extended Tracking.

Therefore if you plan to also release on iOS, our recommendation is to use at least 9.4.

Thank you.

Vuforia Engine Support

Using older versions of Vuforia with newer versions of Unity

February 14, 2021 - 10:58am #5

Is there a 2021 update on this question. I am getting error messages like crazy in Unity2019.4.20f1 using the version of vuforia provided in package manager 8.5.9

 

Using older versions of Vuforia with newer versions of Unity

July 29, 2020 - 2:01am #4

Hi @kmwonghj7186,

The recommended Unity version for Vuforia Engine 9.3 is Unity 2019.4 LTS. The minimum supported version is Unity 2019.3.

Thank you.

Vuforia Engine Support

Using older versions of Vuforia with newer versions of Unity

July 28, 2020 - 5:58pm #3

After upgraded my simple AR project for Android to Unity 2020.1.0f1, Vuforia stopped work and in fact totally disappeared in Unity environment. Tried the latest add-vuforia-package-9-3-3.unitypackage but no luck !! is that only me or Vuforia don't work in Unity any more ????  Tried to reinstall the 2018 Unity version but surprisingly the Andorid SDK is missing !!!   Is that Vuforia don't work in Unity any more ???

Using older versions of Vuforia with newer versions of Unity

July 28, 2020 - 1:18am #2

Hi,

I don't believe it will work, as Vuforia and Unity have performed a lot of changes since the release of 7.5.

For example, Vuforia is now used/installed via the package Manager. This will be the first step that needs to be figered out. Also in 7.5 you needed to activate Vuforia in the XR Settings which are now deprecated in 2019.4.

Thank you.

Vuforia Engine Support

Log in or register to post comments