Topic has a solution and is locked
Topic locked

Using Vuforia with Unity 2019.4.28f1

July 29, 2021 - 11:09pm #1
Topic solved

I've added Vuforia to my project in Unity 2019.4 and I keep getting warnings errors from the moment I turn on Unity and none of  my scenes are playing:

Plugins: Couldn't open /Users/DoubleOseven/New Unity Project/Library/PackageCache/com.ptc.vuforia.engine@d4c3bce7d6a2-1627315709000/Vuforia/Plugins/OSXUniversal/x86_64/FileDriver.bundle/Contents/MacOS/FileDriver, error: dlopen(/Users/DoubleOseven/New Unity Project/Library/PackageCache/com.ptc.vuforia.engine@d4c3bce7d6a2-1627315709000/Vuforia/Plugins/OSXUniversal/x86_64/FileDriver.bundle/Contents/MacOS/FileDriver, 2): Symbol not found: _objc_alloc_init

  Referenced from: /Users/DoubleOseven/New Unity Project/Library/PackageCache/com.ptc.vuforia.engine@d4c3bce7d6a2-1627315709000/Vuforia/Plugins/OSXUniversal/x86_64/FileDriver.bundle/Contents/MacOS/FileDriver (which was built for Mac OS X 10.15)

  Expected in: /usr/lib/libobjc.A.dylib

in /Users/DoubleOseven/New Unity Project/Library/PackageCache/com.ptc.vuforia.engine@d4c3bce7d6a2-1627315709000/Vuforia/Plugins/OSXUniversal/x86_64/FileDriver.bundle/Contents/MacOS/FileDriver

 

(I've attached a screenshot as well of the warnings)

Using Vuforia with Unity 2019.4.28f1

August 6, 2021 - 1:45am #9

It worked. Thank you so much.

Using Vuforia with Unity 2019.4.28f1

August 3, 2021 - 10:11am #8

Hello,

This looks like a specific error while trying to use Vuforia Engine's Driver Framework, in that the Unity project is unable to initialize the driver.

Are you trying to develop with that feature? If so, there is separate documentation unrelated to working with our Core Samples project, which was the issue being addressed below.

Thanks,

Vuforia Engine Support

Using Vuforia with Unity 2019.4.28f1

August 3, 2021 - 3:03am #7

And I used is a laptop

Using Vuforia with Unity 2019.4.28f1

August 3, 2021 - 3:00am #6

Hello

I've added Vuforia to my project in Unity 2019.4 and I keep getting warnings errors from the moment I turn on Unity and none of  my scenes are playing:

Plugins: Failed to load 'D:/AR/unityProject/NewTest/Library/PackageCache/com.ptc.vuforia.engine@4abf7e2fffc6-1627315709000/Vuforia/Plugins/Windows/x64/FileDriver.dll' because one or more of its dependencies could not be loaded.

 

AttachmentSize
Image icon bug.png83.29 KB

Using Vuforia with Unity 2019.4.28f1

July 30, 2021 - 3:49pm #5

Hello,

So I was successful in creating a minimal Vuforia app, run in PlayMode, using Unity 2019.4.28f1 by following these steps:

  1. Download the Engine 10.0 Unity Extension from the developer portal: https://developer.vuforia.com/downloads/sdk
  2. Create a new project in Unity 2019.4.28f1
  3. Import the downloaded .unitypackage file via Assets->Import Package->Custom Package...
  4. Add a Vuforia Engine license key: Window->Vuforia Configuration->Add License
  5. In 'SampleScene', remove the 'Camera' prefab
  6. In 'SampleScene', add the Vuforia Engine 'ARCamera' prefab
  7. In 'SampleScene', add the Vuforia Engine 'ImageTarget' prefab
  8. Add a target in the Inspector window of the ImageTarget prefab
  9. In 'SampleScene', add a 3D Object (Cube, Sphere, etc.) as a child of the ImageTarget prefab. This will register the object's augmention to the Image Target
  10. Run in PlayMode

Note that depending upon the size of your target, you may need to update the scale of the 3D object. For the Vuforia Astronaut, I had to reduce the scale of the cube to "0.05" for X,Y & Z. Otherwise, the augmentation was much larger than the target and thus could not be seen.

Thanks,

Vuforia Engine Support

Using Vuforia with Unity 2019.4.28f1

July 30, 2021 - 1:24pm #4

Hello,

I just did the exact same thing for a different forum question, and it worked perfectly.

Let me try with the same Unity version you're using.

Thanks,

Vuforia Engine Support

Using Vuforia with Unity 2019.4.28f1

July 30, 2021 - 12:23pm #3

I downloaded the Vuforia package for Unity from https://developer.vuforia.com/downloads/sdk and then added it to a completely new Unity project. These errors come up each time I try to play the scene. 

Using Vuforia with Unity 2019.4.28f1

July 30, 2021 - 9:13am #2

Hello,

Can you provide more details on the steps you took to import Engine into your project? It is not clear to me how to troubleshoot the issue with the information provided as the messages do not have enough information to determine the root cause.

Thanks,

Vuforia Engine Support

Topic locked