Log in or register to post comments

Video Background in Scene without ARcamera -Unity 2017.2.0f3

October 23, 2017 - 12:08pm #1

I'm developing an Android app in Unity and I'm having an issue where I'm seeing a video background where I don't want one. I just upgraded to Unity 2017.2.0f3 and I went through the process of migrating my project (https://library.vuforia.com/content/vuforia-library/en/articles/Solution/migrate-vuforia-62-to-65.html).

In my app, the user can switch between two scenes. One scene uses augmented reality, and the other does not. The scene that uses AR has imagetargets, an ARcamera, etc,  while the one that doesn't use AR has none of these things. Before I upgraded to the most recent version of Unity & Vuforia, when I switched to the scene without AR, a default background appeared. After upgrading, the video background persists through both scenes, and switching to the non-AR scene creates new Vuforia game objects where none are supposed to be. For example, when I switch to the non-AR scene, a Vuforia Behaviour script component and a child "Background Plane" object  are created and attached to my main camera, and two new gameobjects appear with image target behaviour scripts attached.

Is there a setting to turn off this behavior? Is this some kind of bug, or did I mess up while doing the migration? I could write a script to destroy these additions when I switch to this scene, but I'm hoping there is a more elegant solution I'm missing.

 

Thanks

 

Edit: Clarity

Video Background in Scene without ARcamera -Unity 2017.2.0f3

October 23, 2017 - 1:11pm #3

That worked! Thanks! 

Video Background in Scene without ARcamera -Unity 2017.2.0f3

October 23, 2017 - 12:57pm #2
Log in or register to post comments