Log in or register to post comments

Video playback not working

July 6, 2017 - 12:28pm #1

I'm able to build and run an app in ios, and have no trouble getting the images recognized and tracked, but am having serious problems with videos not playing. I've tried my video (mp4) and the sizzle reel demo video, and neither will play. If I preview within Unity, I get the "error" icon, and if I use ios I get the "busy" hourglass icon. Any suggestions? Autoplay is checked.

Are there specific encoding formats and resolutions I should be using? I feel like this is a problem with the script, not with the video - since the sizzle reel won't even play.

Using Unity 5.6.1f1 personal.

Help!

Video playback not working

July 7, 2017 - 1:24pm #3

Thanks, but that didn't seem to solve my problem. I re-encoded using the settings you suggested but it's still giving me the hourglass icon when using iOS. Anyone have any other suggestions I can try?

Video playback not working

July 6, 2017 - 2:27pm #2

Unfortunately, videos will not play back in the editor (only on the mobile device) which makes them a pain to test. 

ios is also pretty picky when it comes to encoding. Here's the doc on ios Media Layer with all the specs. I tend to stick to this one below with no problems so far:

  • H.264 video, up to 1.5 Mbps, 640 by 480 pixels, 30 frames per second, Low-Complexity version of the H.264 Baseline Profile with AAC-LC audio up to 160 Kbps, 48 kHz, stereo audio in .m4v, .mp4, and .mov file formats

Another good practice is to always put your .mp4 directly into the 'StreamingAssets' folder in Unity and to just use the video name as the Path in Video Playback Behaviour (good: videoName.mp4) (bad: \StreamingAssets\videoName.mp4). 

Log in or register to post comments