Log in or register to post comments

Videobackground Black In AssetBUndle scene

April 20, 2021 - 6:17am #1

Hi ... anybody,

I've seen posts on this subject but either with no replies or suggested workarounds are not the solution.

I'm using Vuforia 8.5.9 (not an option to go to newver version) and Unity 2019.4.22 for Android project.

It's a quite simple task which works perfectly in editor but not when the app is built and run on mobile device: AR scene is stored in assetbundle.

It really does not matter whether dataset is stored in the StreamingAssets or loaded from AssetBundle because the problem is the same.

When the scene is loaded (completely) videobackground is black although recognition works. When I point camera to the marker it triggers it and brings digital content. But the rest of the screen is black.

What I tried w/o success:

Solution 1) I've put all Vuforia shaders in Resource folder to have them present all the time

Solution 2) I've included Custom/Videobackground shader via ProjectSettings

Solution 3) I've refreshed (re-assigned) Videobackground shader on BackgroundPlane child object of ARCamera through OnVuforiaStarted

Solution 4) I've tried to exclude OpenGL 3.0 from the build

I'm checking the status of BackgroundPlane object and its renderer. Its true. I'm chacking status of BackgroundBehaviour and it's true. Once again, markers tracking works. It's only about VideoBackground is black.

Obviously it's something about material or shader. I've explained what I did with the shaders. SInce this version of Vuforia instantiates material itself (I can't find it anywhere in Vuforia files) I don't know how to place it in AssetBundle.

I simply ran out of the solutions

Can anybody give a hand?

Videobackground Black In AssetBUndle scene

April 22, 2021 - 6:15am #2

Hi,

I believe the shader from 8.5.9 is not compatible with 2019.4.

In general we recommend at least 9.x with 2019.4 LTS.

One thing that you could try is to use the shader from the Core Samples/9.8 and see if that works.

Thank you.

Vuforia Engine Support

Log in or register to post comments