Log in or register to post comments

Viewport rendering incorrect switching from AR to VR Vuforia 6.2.10 Unity 5.4.2f2

April 28, 2017 - 8:06am #1

Hi,

I need help about this issue:

If I try the AR/VR sample all run correctly on iOS 10 BUT in that sample the switch is in the About scene, then unless AR initialized.

My app run in AR and when I focus a marker I shows a button to switch to the VR, in attachment the screenshot about the viewport rendering.

The viewport is not in stereo mode, the gaze isn't centered and there isn't any settings for the cardboard.

In the Digital Eyewear settings I use Video See-Through, Vuforia as Stereo Camera Config and Cardboard v1 (Google) as Viewer type but if I change to another viewer the result is the same.

I don't understand why the sample app run correct and my app not, they are the same settings.

Someone had experience with mix AR/VR or this issue?

Many thanks!

AttachmentSize
Image icon ViewportRendering.png303.23 KB

Viewport rendering incorrect switching from AR to VR Vuforia 6.2.10 Unity 5.4.2f2

May 4, 2017 - 8:49am #2

Hello,

There have been multiple reports from the community of the stereoscopic mask being displaced on iOS devices:

https://developer.vuforia.com/forum/ios/stereoscopic-mask-changes-when-image-target-activated

https://developer.vuforia.com/forum/ios/wrong-stereo-image-iphone-5-vuforia-6-ar-vr-sample

https://developer.vuforia.com/forum/unity-extension-technical-discussion/avvr-sample-displaying-incorrectly-iphone-5-and-7

We have opened a bug report on the issue and hope to have the issue resolved in an upcoming release.

One observation that has been made is that the issue corrects itself upon target recognition. Are you seeing something similar?

Thanks.

Log in or register to post comments