Topic locked

Vuforia 10.3.2 license key not working

December 15, 2021 - 4:58am #1

Hi, I'm new in Vuforia. I have done my first project using Vuforia 9.8 and it worked well. Now I want migrate it to 10.3.2.

But when I completed the migration, I found Vuforia cannot work. The watermark didn t show. I tried to apply a new basic license, but there was still no watermark and the AR could not work.

I cannot find the solution. Please hlep me.

Vuforia 10.3.2 license key not working

December 17, 2021 - 8:40am #8

Hello,

Great work isolating the issue!

Don't feel bad. Many have stumbled upon the same issue, and did not discover the root cause as quickly as you.

Kind regards,

Dave Downing

Technical Support

Vuforia 10.3.2 license key not working

December 17, 2021 - 7:07am #7

"To confirm, are you aware that the new, Basic license (created >= 11/16/2021) no longer watermarks many of the features in Engine SDK versions 10.3.2 and greater?"

- I didnt aware that. Thanks very much for correcting me.

 

Now I find the solution. In 9.8.11, I built the project with Mono because IL2CPP building always failed. After migrating, the minimum ARCore library version does not support Mono (Armv7). So I unchecked "include ARCore Library" and that made AR not work.

Now I solved problem of IL2CPP building. My project works now.

Sincere thanks from a novice again haha.

 

 

Vuforia 10.3.2 license key not working

December 17, 2021 - 4:58am #6

Hello,

To confirm, are you aware that the new, Basic license (created >= 11/16/2021) no longer watermarks many of the features in Engine SDK versions 10.3.2 and greater?

https://library.vuforia.com/faqs/pricing-and-licensing-options

Perhaps I'm misunderstanding, but it almost sounds like you're expecting to see a watermark when using the new license key and SDK 10.3.2.

As far as why you're no longer able to get the AR functionality to work, that is a more challenging question to answer with limited information. Our typical recommendation is to download our free Unity Core Samples as a baseline project to confirm that Engine is working. If the AR functionality in the Core Samples works with your new license key, then this project can be used as a baseline to compare with your existing project settings.

Kind regards,

Dave Downing

Technical Support

Vuforia 10.3.2 license key not working

December 16, 2021 - 8:23pm #5

Hello,

Thanks for your reply. 

I cannot find any problem with project migration. I followed the migration guide in Vuforria Library. And there is no error or warning.

And in my understanding, even though there is any setting for AR function not correct, as long as the license is working, at least the AR camera should show a Vuforia wartermark. (Please correct me if I'm not right. I'm novice in Vuforia haha)

And it is strange that when I delete the key and start to play, the watermark shows successfully. (Of course functions based on AR didnt work without license.)

I just cannot figure out why this happens. 

 

Vuforia 10.3.2 license key not working

December 16, 2021 - 9:47am #4

Hello,

In our experience, issues observed during migration to a newer version of Engine are not license related.

Additionally, keys generated before the updated licensing (on 11/16/2021) are still compatible with later versions of Engine SDK.

Thus, if your app was having problems after migrating to Engine SDK 10.3.2, it is most likely a result of the migration and not a change in the license key.

Can you confirm that the migrated app does not work with either license key, new or old? From your description, this seems to be the case.

Kind regards,

Dave Downing

Technical Support

Vuforia 10.3.2 license key not working

December 16, 2021 - 7:45am #3

Hi, I'm using Unity 2020.3.24f1c2 for Vuforia 10.3.2

Vuforia 10.3.2 license key not working

December 15, 2021 - 6:32am #2

Hey there,

 

Which Unity version are you running?

 

Kind regards,

Patrick Scheper

Technical Community Manager

Topic locked