Log in or register to post comments

Vuforia 7 Autofocus (ARKit)

November 7, 2017 - 8:27am #1

Im using Unity 2017.3b8 and using Vuforia with image targerts.

It seems that the current Vuforia Version if the application is running on a ARKit ready device will disable the autofocus / the ARkit integration is disabeling it.

This makes it nearly impossible ot use it with image marker that are around a normal A4 size or smaller since the iPad Pro camera for example never focuses on a reasonable distance to such markers.

Is there any way to disable the Integration or overwrite the autofocus behavior?

Setting the Camera focus mode to FOCUS_MODE_CONTINUOSAUTO will result in a sucsess massage in the XCode console but no actual result (no working auto focus).

And not going back to 2017.2is not an option since the app has to build to Andorid too and 2017.2 has a massive not fixed bug with realtime shaddowson most Android devices.

 

Vuforia 7 Autofocus (ARKit)

April 4, 2018 - 4:32pm #15

Also looking for solution to this problem, only some VuMarks will work with this issue, due to loss of focus. This issue makes VuMark recognition unusable.

Will this be corrected in the next Vuforia release?

I think Vuforia should reconsider being tied to Unity releases to update the Vuforia library or have a method for a Vuforia SDK hot patch while waiting for a Unity release. 

Vuforia 7 Autofocus (ARKit)

March 31, 2018 - 1:24pm #14

When will this error with autofocus be solved? Because of it, I was forced to roll back to version 6.5, but for older versions there will be no official patches to solve the  problem with the publication of the app on ios (ipv6 bug).

As for the autofocus, I already wrote in the parallel topic https://developer.vuforia.com/forum/vuforia-api/camera-focus-not-working

Vuforia 7 Autofocus (ARKit)

March 20, 2018 - 7:53am #13

+1

 

is or will there be any solution for this problem soon?

Vuforia 7 Autofocus (ARKit)

March 19, 2018 - 3:06am #12

+1

Vuforia 7 Autofocus (ARKit)

March 16, 2018 - 3:48pm #11

Unfortunately the lack of AutoFocus is making it impossible for us to update to Vuforia 7 for our iOS app. Focus was working beautifully in Unity 2017.2.1 Vuforia v6.2.6. We are trying to update to Unity 2017.3.1f1 Vuforia 7.0.47 and the camera will not focus using FOCUS_MODE_CONTINUOUSAUTO.

It looks like this is a problem with ARKit. Currently we are only using image trackers (not markerless tracking) so is there any word on a quick fix/update/work around we could look into? I would appreciate any update if this is on the roadmap.

Vuforia 7 Autofocus (ARKit)

February 12, 2018 - 5:22am #10

+1 We're having focus problems on iOS, too. Would love to see a fix soon!

Vuforia 7 Autofocus (ARKit)

February 5, 2018 - 8:39pm #9

same question - how do you get older vuforia to work with the current version of iunity - v6 supports 1080p on iOS unity but issue with 2017.3.0f3 

Vuforia 7 Autofocus (ARKit)

January 30, 2018 - 2:44am #8

HI tajino,

Sorry to jump in on this thread. I was wondering: how is it possible to use an older version of Vuforia with those versions of Unity that already integrate it? Do you import the old Vuforia asset package? I'm interested in doing the same thing as using ARKit is giving me all sorts of problems.

Thank you so much

Vuforia 7 Autofocus (ARKit)

January 28, 2018 - 4:32am #7

Besides autofocus issue with ARkit, I've also noticed that the camera auto exposure is not at good when compared to pre-ARkit 6.2.10 auto exposure. It is pretty obvious in low light.

Would it be possible to get the camera's current auto white balance/color temperature value? So that way we could adapt our 3D lighting in Unity to match that of the camera feed.

Vuforia 7 Autofocus (ARKit)

January 28, 2018 - 4:26am #6

Hope this gets fixed soon.

I'm currently reverting back to using Vuforia 6.2.10 in Unity 2017.3.0p3.

Works ok as a workaround for now with some deprecated code warning, but overall it works.

Vuforia 7 Autofocus (ARKit)

January 22, 2018 - 3:36pm #5

No update as of today slmille4.

Thanks,

Vuforia Support

Vuforia 7 Autofocus (ARKit)

January 19, 2018 - 12:52pm #4

Has this been fixed yet?

Vuforia 7 Autofocus (ARKit)

December 12, 2017 - 5:03am #3

Autofocus issue still persists in 2017.3.0f2 and we cannot revert 2017.2 due to bug in Unity's Video player.

Also, sometimes the video background does not fill the entire screen and edges are constantly flashing.

Vuforia 7 Autofocus (ARKit)

November 7, 2017 - 2:02pm #2

Hello MoritzN,

This is a known issue in Vuforia 7 that will be addressed in a future release.

Thanks,

-Vuforia Support

Log in or register to post comments