Log in or register to post comments

Vuforia 7.1.34 for Unity2018 is broken

May 10, 2018 - 9:19am #1

Anyone else getting the problem of Vuforia not installing properly?

Im installing the update to the Unity 2018 install root (C:\Program Files\Unity), then once its installed, im reopening unity and i'm greeted with



"Unloading broken assembly Library/ScriptAssemblies/Assembly-CSharp.dll, this assembly can cause crashes in the runtime"

and

"Unloading broken assembly Library/ScriptAssemblies/Assembly-CSharp-Editor.dll, this assembly can cause crashes in the runtime"

I've tried deleting those two as well as the entire library folder in order to regenerate it properly, however no success.

Running the Unity package from: https://developer.vuforia.com/forum/unity/workaround-ios-apps-failing-review



then causes the wall-to-wall errors of anything vuforia related in the project.

Vuforia 7.1.34 for Unity2018 is broken

May 21, 2018 - 2:31pm #7

I can also confirm that UnitySetup-Vuforia-AR-Support-for-Editor-2018.1.exe will not install Vuforia 7.1.34 when Unity is installed using Unity Hub. Is this something you guys can work out with Unity?

The location of the Unity.exe is in two places:

1.) C:\Program Files\Unity\Hub\Editor\2018.1.0f2\Editor\Unity.exe

2.) C:\Program Files\Unity\Editor\Unity.exe

Vuforia Installer is not able to see either one. :/

Please advise.

AttachmentSize
Image icon VuforiaUpgradeFail.jpg17.21 KB

Vuforia 7.1.34 for Unity2018 is broken

May 11, 2018 - 2:25am #6

I GOT VUFORIA 7.1.34 INSTALLED ON AN EMPTY PROJECT

Sorry for the caps, i just want to make sure that the next poor soul who also encounters this finds this solution. It appears our overzealous IT guy has locked my machine down so much that the Vuforia 7.1.34 installation does not fully install unless it is installed as an Admin. That goes for Unity2018 too.

When installing the Vuforia update, make sure you do it as admin otherwise it will not be installed properly and you will not get notified of it.



EDIT: Its also worth mentioning that Unity2018 needs to be ran as an Admin, otherwise Vuforia S***s itself. Good luck

Vuforia 7.1.34 for Unity2018 is broken

May 11, 2018 - 1:32am #5

Im upgrading from 2017.3.1f1 to 2018. Looking in a detached head of the latest 2017.3.1f1 commit, there are no errors.

I have just re-downloaded 2018, created a fresh project, updated vuforia to 7.1.34 and the same thing occurs:



"Unloading broken assembly Library/ScriptAssemblies/Assembly-CSharp.dll, this assembly can cause crashes in the runtime"

and

"Unloading broken assembly Library/ScriptAssemblies/Assembly-CSharp-Editor.dll, this assembly can cause crashes in the runtime"

 

As well as every vuforia related script throwing errors basically saying vuforia could not be found.

Vuforia 7.1.34 for Unity2018 is broken

May 10, 2018 - 10:28am #4

That is the correct place to install the package.

Do you get this error in all projects that have Vuforia activated in them? Did you migrate a project from 2017.X to 2018.1 before upgrading Vuforia in 2018? If so, was this project displaying any other issues?

Thanks,

Vuforia Support

Vuforia 7.1.34 for Unity2018 is broken

May 10, 2018 - 9:59am #3

Unfortunatly ive reinstalled it several times in my attempts.

Am i right in assuming 7.1.34 needs to be installed in programfiles/unity/ ?

There are multiple threads stating similar issues how have you not encountered this already?

Unity dlls are breaking from the update.

Vuforia 7.1.34 for Unity2018 is broken

May 10, 2018 - 9:38am #2

Hello AGamlin,

You won't need that Unity Package when using Unity 2018 as the functionality is provided internally in the SDK.

In terms of your other issue, this is not something we have encountered when upgrading to Vuforia 7.1.34 in Unity 2018, if it continues to give you errors it might be worth trying a reinstall.

Thanks,

Vuforia Support

Log in or register to post comments