Log in or register to post comments

Vuforia 8.1.7 can't create archive on iOS

April 24, 2019 - 12:42am #6

Hey,

I'm using Unity 2019.1.0f2 and when I create an archive on iOS I get this error. Note it works fine on device.

Any ideas? Thanks.

AttachmentSize
Image icon Screenshot Xcode error3.64 MB

Vuforia 8.1.7 can't create archive on iOS

April 30, 2019 - 4:12am #5

Hello,

 

The same happens to me. I can 'play' the app on my iPad, but cannot generate an IPA file to upload to stores.

Is anyone else experiencing this issue?

Vuforia 8.1.7 can't create archive on iOS

April 30, 2019 - 4:59am #4

As a workaround, you can set the architecture in Unity to compile only for ARM64, in player settings, as attached in the screenshot.

Hope Unity-Vuforia solve this soon.

AttachmentSize
Image icon player_settings_arch.png5.7 KB

Vuforia 8.1.7 can't create archive on iOS

April 30, 2019 - 7:43am #3

Vuforia no longer supports 32bit iOS builds, please see our release notes: https://library.vuforia.com/content/vuforia-library/en/articles/Release_Notes/Vuforia-SDK-Release-Notes.html

We should have added a build error if 32bit architectures are still included. This will be added in the next release.

Thanks, Vuforia Engine Support

Vuforia 8.1.7 can't create archive on iOS

May 14, 2019 - 1:02am #2

DaVikingCode wrote:

Hey,

I'm using Unity 2019.1.0f2 and when I create an archive on iOS I get this error. Note it works fine on device.

Any ideas? Thanks.

 

Hi, same issue here, any help?

Vuforia 8.1.7 can't create archive on iOS

May 23, 2019 - 2:02am #1

Vuforia Engine currently only supports a min iOS version of 11.0 and ARM64. Are you sure you have your PlayerSettings set correctly to target iOS 11.0+? By default it's set to a lower version. You should be seeing an error message in the log after building the app in Unity if you have a lower SDK version set.

Setting to ARM64 would also solve this issue, but Vuforia still only supports iOS 11.0+

Could you confirm that setting the correct iOS SDK version fixes your issue?

Log in or register to post comments