Log in or register to post comments

Vuforia built in Unity gameplay not working

June 12, 2020 - 7:16pm #1

I am working on a Unity 2019 3.1f1 with the latest Vuforia version installed. I was building a game with multiple phases, with the AR camera activated at all times. This game is already built and it's currently being executed in the latest Android version (a Xiaomi mi 9 to be exact). What's supposed to happen is after a coin toss, the game mechanics for either offence or defence would be executed (depending on which side of the coin is it on), but what actually happened is that the gameobject is displayed, but the scripts are not being executed at all, despite the very same game being executed properly in both play mode and in the device simulator.

This is what it looked liked when I executed it in Unity:

 

Successful Mechanic shown through Unity Editor

And this is what it looked like after being built and installed in the phone:

Built game that doesn't execute game code.

Is there a way to gather debug information when the game is being executed in the phone, so that I would be able to find out what exactly went wrong when I executed the App? Mainly because it seems that any other options are off the table, including the Unity Remote method, which can't be used for debugging since Vuforia didn't support it, and we did tried it, but it didn't show up.

Thanks in advance!

AttachmentSize
Image icon asdasd.png218.81 KB
Image icon asdvff.jpg31.48 KB

Vuforia built in Unity gameplay not working

June 24, 2020 - 6:06am #5

So, I made the necessary changes, among other things. And I tested the game through Unity Remote, and it worked properly. But when I ran it through the phone after building, nothing happens other than showing me a static prefab. The screen I setup to show OnTrackingLost() and the script to show in OnTrackingFound() didn't show up, except for the little Debug Log I placed every update to show the Rounds in the game in the master script.

Here's the logcat of the run in the app:

https://hastebin.com/ixogifokiq.coffeescript

Can any tell me how to fix this?

Vuforia built in Unity gameplay not working

June 22, 2020 - 11:51pm #4

Yeah, even with the function added, the script isn't running at all, even though it ran properly in unity.

 

I may need help in this regard, especially since every script relied on the stateMachine Script to run.

Vuforia built in Unity gameplay not working

June 21, 2020 - 3:25am #3

How would I be able to use logcat if the app is already installed in the phone?

Also, the script is executed at the start by a master script that controls all other functions, so no, I didn't use OnTrackingFound in the script.

Vuforia built in Unity gameplay not working

June 17, 2020 - 5:58am #2

Hi,

You need to check in logcat if the event is triggered. Are you using the OnTrackingFound() to trigger this events?

Thank you.

Vuforia Engine Support

Log in or register to post comments