Log in or register to post comments

Vuforia Core Samples broken after upgrade

February 1, 2019 - 11:10am #1

I just updated to 2018.3.3f1 Vuforia 8.0.10 and loaded the core samples. I now get "The associated script can not be loaded" on every script in the core samples and in the console:

"Assets/Vuforia/Editor/Scripts/OpenSourceInitializer.cs(53,11): error CS0535: `OpenSourceInitializer.DefaultBehaviourAttacher' does not implement interface member `IDefaultBehaviourAttacher.AddDefaultModelRecoEventHandler(UnityEngine.GameObject, Vuforia.ModelTargetBehaviour)'"

I can't seem to figure out why the scripts aren't working. There is nothing else in the new project after upgrading. I did upgrade with the hub but I can't see why that would be a problem?

Any help would be much appreciated.

 

Vuforia Core Samples broken after upgrade

February 1, 2019 - 1:01pm #2

So i think I figured out the issue for anyone having similar issues. When using the hub the asset store does not automatically adjust to the correct version of the core samples. You must manually go to ~/Library/AssetStore and remove any Vuforia sample packages. This will force Unity to download the correct version from the asset store. This way you can have two different versions of unity and vuforia on the same system.

Log in or register to post comments