Log in or register to post comments

Vuforia Failed To Initialize - iOS 13.3

December 30, 2019 - 12:03pm #6

My graphics apis are set to OpenGlES3 on top, Metal on bottom.

Whenever my app (which is using delayed initialization) attempts to initialize Vuforia, it fails on any iPhone X series or later using iOS 13.3. Older iOS versions do not appear to have this problem. This applies to all Vuforia versions tested in the 8 series.

In addition, when I click on the Vuforia Configuration file inside Unity 2019.2.17 on Mac, it crashes Unity. This issue only presents itself with projects that import the most recent Vuforia package, 8.6.7.

Vuforia Failed To Initialize - iOS 13.3

December 30, 2019 - 1:20pm #5

Went into the console, and this is the bottom message from Vuforia:

ERROR/AR(764) VideoBackgroundConfig with screen size of zero received, skipping config step

Vuforia does successfully initialize before this point. Camera stays off.

Vuforia Failed To Initialize - iOS 13.3

January 8, 2020 - 9:03am #4

The crash on Mac when trying to edit the Vuforia Configuration is our only remaining issue at this point. We've downgraded Vuforia to 6.5.9 to resolve that problem.

Vuforia Failed To Initialize - iOS 13.3

January 10, 2020 - 3:43am #3

Hi @btsudios

Could you please provide us the entire xcode output after building the application on iOS 13.3? and would it be possible to provide us the project via pm?

In addition could you please confirm the Mac OS and Xcode version?

@NoovieARcade

Could you please confirm the Unity and Mac OS version you are seeing the behavior?

Thank you.

Vuforia Engine Support

Vuforia Failed To Initialize - iOS 13.3

February 28, 2020 - 9:34am #2

I'm having this same issue, is there any updates on this issue? 

The device i'm having issues on is this:

  • Unity: 2019.2.12f1
  • Vuforia: 8.5.9
  • Xcode: 11.3.1
  • Device: iPhone Xs Max
  • iOS 13.3.1

Errors from xcode when deploying to this device: 

Start Vuforia Engine

Vuforia.VuforiaARController:StartVuforia(Boolean)

Vuforia.VuforiaARController:StartAfterInitializationCompleted()

System.Reflection.MonoMethod:Invoke(Object, BindingFlags, Binder, Object[], CultureInfo)

System.Delegate:DynamicInvokeImpl(Object[])

Vuforia.DelegateHelper:InvokeDelegate(Delegate, Object[])



(Filename: ./Runtime/Export/Debug/Debug.bindings.h Line: 35)

cameraDeviceStartCamera

2020-02-28 12:29:44.096548-0500 [1994:26983] INFO/AR(1994) 2020-02-28 12:29:44: Starting camera with profile for iPhone11,6, 800.1

2020-02-28 12:29:44.098469-0500 [1994:26983] ERROR/AR(1994) 2020-02-28 12:29:44: VideoBackgroundConfig with screen size of zero received, skipping config step

The app stops here and never recovers.

However the same app, same build deploys to this:

  • Device: iPhone X
  • iOS: 13.2.3

I still get the error about `VideoBackgroundConfig with size of zero receives, skipping config step`, however it recovers and works as intended. this is the output following that error:

2020-02-28 12:33:12.106977-0500 [3644:2830586] [Technique] Error pushing pixel buffer to VIO: InvalidCalibrationData

2020-02-28 12:33:12.110422-0500 [3644:2830586] [Session] Session (0x12023a3a0): did fail with error: Error Domain=com.apple.arkit.error Code=200 "World tracking failed." UserInfo={NSLocalizedDescription=World tracking failed., NSLocalizedFailureReason=World tracking cannot determine the device’s position.}

 

Vuforia Failed To Initialize - iOS 13.3

March 5, 2020 - 11:31pm #1

Hi,

There are some issues with Xcode 13.3.1, as per https://stackoverflow.com/questions/60015309/running-ios-apps-causes-runtime-error-for-frameworks-code-signature-invalid%C2%A0 the workaround is to use a paid apple developer account.

Could you please confirm that you are using a paid apple developer account and receiving this error?

Thank you.

Vuforia Engine Support

Log in or register to post comments