Log in or register to post comments

Vuforia - Image Target and iOS Build error 21 arm 64

October 18, 2019 - 1:45am #1

Hi everyone,

I'm new to Unity/Vuvoria developing and I'm having trouble with building the project for iOS arm 64 architecture.

The project is very simple, just a sample with an AR Camera and an Image Target, and it works correctly on my mac if I run the scene from the editor.

I already configured the 'Build Settings' (attached images) as described in the documentation with no results.

I tried to generate the Xcode project with Unity 2018.4.11f1 and 2019.2.9f1 and the latest Vuforia plugin 8.3.9.

I already tried:

  • to disable "Metal editor support"
  • to disable "Auto Graphics API" and select OpenGLES2 and OpenGLES3 without Metal
  • to specify only arm64 architecture

Unity creates the Xcode project but when I try to build or run on a device I receive always the same error:

"ld: can't open output file for writing: /Users/xxxx/Library/Developer/Xcode/DerivedData/Unity-iPhone-bjbbbigbzutzrfdjozfpcjuypacn/Build/Products/ReleaseForRunning-iphoneos/vuforia.app/vuforia, errno=21 for architecture arm64

clang: error: linker command failed with exit code 1 (use -v to see invocation)"

I hope someone can help me to resolve this problem because I'm freaking out.. :D

Thanks

Stefano

ps my Mac is running macOS Catalina 10.15

 

Vuforia - Image Target and iOS Build error 21 arm 64

October 22, 2019 - 7:16am #2

Hello,

Based on the provided output the issue seems to be when xcode is compiling, not related to unity or vuforia engine.

Searching online there are several findings that might help you, for example try this.

Thank you.

Vuforia Engine Support

Log in or register to post comments