Log in or register to post comments

Vuforia initialization failed

May 13, 2017 - 8:53pm #1

Hello

I really don't know where to start looking, so I would like your opinion here.

I took the Vuforia sample project (the one with the teapots) as base to construct another project.

Everything was going well until I *must* have done something wrong, that screwed my project and now it won't run.

FYI a crash happened earlier today, I submitted a crash report for that.

 

I know my question is extremely broad, but could you tell me where to look in order to find this error?

The console throws this error before jumping to my AR scene:

Vuforia cannot be started before it is initialized.

Please disable Delayed Initializationin the Vuforia configuration or initialize Vuforia manually with the VuforiaRuntime-class.

UnityEngine.Debug:LogError(Object)

Vuforia.VuforiaARController:Start()

System.Delegate:DynamicInvoke(Object[])

Vuforia.DelegateHelper:InvokeDelegate(Delegate, Object[])

Vuforia.DelegateHelper:InvokeWithExceptionHandling(Action)

Vuforia.VuforiaAbstractBehaviour:Start()

 

Any help will be really appreciated.

 

Thanks.

-E

 

Vuforia initialization failed

March 14, 2018 - 8:12am #4

Hello,



I first came across this problem when I inserted another scene into the hierarchy along with the existing scene.



Restarting vuforia fixed it for me.



Hope it helps.

Thank you.

Vuforia initialization failed

May 15, 2017 - 12:20pm #3

The issue fixed itself when I rebooted the computer.

I am using OSX.

Thanks for your support!

Vuforia initialization failed

May 15, 2017 - 10:47am #2

Hello,

The only thing I can think of is that you're calling a Vuforia API before the SDK is initialized. Are you sure you've included the ARCamera prefab in your scene?

Thanks.

Log in or register to post comments