Log in or register to post comments

Vuforia Initializing Itself!

October 19, 2017 - 11:57pm #1

Umm, I hope this is something I've overlooked. But it seems Vuforia (6.5, Unity 2012.2) is instantiating itself in every scene of my game. It's adding itself to the Main Camera and causing havok. My game is completely broken right now. I've tried turning on "Delayed Initialization" but then just get this error:

Vuforia cannot be started before it is initialized.

Please disable Delayed Initializationin the Vuforia configuration or initialize Vuforia manually with the VuforiaRuntime-class.

UnityEngine.Debug:LogError(Object)

Vuforia.VuforiaARController:Start()

System.Delegate:DynamicInvoke(Object[])

Vuforia.DelegateHelper:InvokeDelegate(Delegate, Object[])

Vuforia.DelegateHelper:InvokeWithExceptionHandling(Action)

Vuforia.VuforiaBehaviour:Start()

 

I've even turned off "Enable Play Mode"

Yet still, Vuforia magically instantiates itself.

Sure, Vuforia is a great piece of technology, and I guess some might argue it should be in every scene of every game ever made. But I'd rather decide that for myself thanks.

How can I stop Vuforia from initializing itself in scenes where no Vuforia object even exists!

Vuforia Initializing Itself!

March 6, 2019 - 8:58am #5

Step 1: open Vuforia Configuration 

Step 2: go to Global

Step 3: uncheck Delayed Initialization 

Donnnnne !

Vuforia Initializing Itself!

October 22, 2018 - 7:40pm #4

Ookbee wrote:

got the same problem, did you find anything? I remember having this problem when I worked on VR as well, must be some kind of configuration but I just can't find it.

Vuforia Initializing Itself!

October 20, 2017 - 1:47pm #3

There's a lot of discussion about this going on in the Unity Vuforia forum.  Seems they understand it's an issue and are working on a better solution.

Here's the official fix for the time being:

When Vuforia AR Support is activated in XR Settings, it is enabled for every scene in your project. In this way Vuforia support behaves like an XR Support Device - it's automatically configured and available in a scene.

To disable Vuforia in a scene, you need to disable the Vuforia Behaviour.

To disable on the Main Camera, add a VuforiaBehaviour script from Component > Scripts > Vuforia in the menu.

Then disable (uncheck) that script component.

To disable on an ARCamera, simply disable on the ARCamera GO.

https://forum.unity.com/threads/do-not-run-vufory-when-the-application-starts.498351/#post-3242948

Vuforia Initializing Itself!

October 20, 2017 - 2:00am #2

got the same problem, did you find anything? I remember having this problem when I worked on VR as well, must be some kind of configuration but I just can't find it.

Log in or register to post comments