Log in or register to post comments

Vuforia, MRTK & HoloLens

July 26, 2019 - 6:25am #1

Hi,

I am currently trying to create a simple HoloLens app using Vuforia, for image referencing and the MRTK to interact with the Augmented Object. 

I am able to get an app running on the HoloLens using Vuforia on its own and I can get an app running using just the MRTK. When I try to use both in the same Unity project though, the app will run but wont show the Augmented model and will usually crash out. 

I have tried various different things to resolve this but none have worked yet. Has anyone else had any luck with combining the two? If not, does anyone have any recommendation on how best to interact with an AR Object using Vuforia on its own with the HoloLens? e.g. being able to select the AR content, play an animation, allow the use of gestures etc.

 

Unity 2018 3.14f

MRTK v2.0.0-RC2.1

Visual Studio 2017

HoloLens 1 

 

Thanks in advance. 

Vuforia, MRTK & HoloLens

July 26, 2019 - 9:49am #2

Hello,

The Vuforia HoloLens sample on the Asset Store has some Holotoolkit (HLTK) scripts and resources. The complete HLTK is fairly large, so we cherry-picked simpler concepts for implementation. The HLTK content that is original and unmodified is stored in the Assets\HoloToolkit folder of the VuforiaHoloLens sample.

My understanding is that the entire MRTK library is vast and extensive. Thus, we suggest only pulling in the required resources as needed.

Thanks,

Vuforia Engine Support

Log in or register to post comments