Log in or register to post comments

Vuforia SDK Install

January 25, 2021 - 12:28am #1

I have been trying to install this for weeks and now tried on a brand new PC with Unity 2019.4.17 and it still has the same issue. Drop the package in the assets and import them and I get this

An error occurred while resolving packages:

  Project has invalid dependencies:

    com.ptc.vuforia.engine: No 'git' executable was found. Please install Git on your system then restart Unity and Unity Hub

A re-import of the project may be required to fix the issue or a manual modification of C:/Users/Admin/New Unity Project/Packages/manifest.json file.

 

I have searched for answers and tried some including removing the manifest file or removing lines from it. Installed git, nothing works. Does this only work on previous and specific versions of Unity? I'm about to give up on it after having done some useful work a year ago with it.

Vuforia SDK Install

February 3, 2021 - 1:57am #5

Hi @neatgadgets, @osgut,

If the installation fails via script , please try the other 2 options mentioned in this article: https://library.vuforia.com/articles/Solution/vuforia-engine-package-hosting-for-unity.html

Thank you.

Vuforia Engine Support

Vuforia SDK Install

January 27, 2021 - 10:04am #4

Problems with any version of unity , 2019 and 2020, its a headake!!!

AttachmentSize
Image icon vuforia engine instalation problem.png131.04 KB

Vuforia SDK Install

January 25, 2021 - 1:23am #3

Downloaded the package from https://developer.vuforia.com/downloads/sdk

Dragged iadd-vuforia-package-9-6-4 onto the Assets area as you do with any other unity package 

Error comes up

 

It did ask to update which I did, ie update the vuforia package from git, if you say yes then came up with the error. The error says while trying to resolve...

If you say no nothing happens.

Vuforia SDK Install

January 25, 2021 - 12:59am #2

Hi,

Could you please elaborate on how you install it? Did you use the script? What do you mean with drop the package?

I've tested the installation with the script found here: https://developer.vuforia.com/downloads/sdk and it worked as expected.  Please note that sometimes the process of downloading the package will be longer than expected and in Unity there will be a prompt Resolving package...; please let it finish, the installation is not blocked.

Thank you.

Vuforia Engine Support

 

Log in or register to post comments