Log in or register to post comments

Vuforia Wrapper error with Unity module inside Android Studio project

March 14, 2018 - 8:25am #1

Hi!

I have Unity 2017.3.1f1, Vuforia 7 and Android Studio 3.0.1. To run the unity module in AS i export it from unity to an android build using gradle. I then change the build.gradle and manifest to correspond to my respective AS versions and also changing it from an application to a library. After this i import a new module in my already existing AS project using Import AAR or Import Gradle project (I've tried both).

Now if the Unity project doesn't contain Vuforia im all good and it works just like it has before. But if i include it, it returns an error. "Failed to resolve module :VuforiaWrapper:". My guess is that it cant find the file VuforiaWrapper.aar even though i see it in the project tree in the folder 'libs'.

The second line is the one causing the trouble, should i use a path or something? What have i missed?

Quote:



dependencies {

    compile fileTree(dir: 'libs', include: ['*.jar'])

    compile(name: 'VuforiaWrapper', ext:'aar')

}

Vuforia Wrapper error with Unity module inside Android Studio project

September 17, 2019 - 12:42pm #5

I did as @Johnny94 said. The project is working fine, but VuforiaWrapper.aar has 32-bit native code which Play Store no more uses. Any fix for that? If I do not include VuforiaWrapper.aar, a black screen is shown in that Activity and play store accepts the app bundle. But if I include it, while uploading on Play Store, it shows 32-bit native code error.
Please help. I have spent weeks searching for this.

Vuforia Wrapper error with Unity module inside Android Studio project

April 20, 2018 - 12:00pm #4

Import -> New Module -> Import VuforiaWapper.aar

 

write in Settings.gradle

include ‚:VuforiaWrapper‘

Both Should be Upper quotes 

add to you App dependencies 

compile project(‚:VuforiaWrapper‘)

Both Should be Upper quotes

 

if Compile is obsolete Text implementation

 

Sync grade Project 

 

 

this worked for me

Vuforia Wrapper error with Unity module inside Android Studio project

April 5, 2018 - 4:42pm #3

Do u found a solution?? The previous one didn't do anything with me ,I really stuck with it please tell me

Vuforia Wrapper error with Unity module inside Android Studio project

March 18, 2018 - 4:30am #2

Hi. I had exactly the same problem and fortunately I found out the cause after many tries. The cause of this problem is due to repository configuration inside the Module:

repositories {

    flatDir {

       dirs 'libs'

    }

}

 

As you run the Gradle of the main application, this configuration will be considered from the base directory of the main project not the Module itself. Therefore, one easy way I found to fix this problem was to copy VuforiaWrapper.aar file inside the libs folder in main app besides the main build.gradle file and it started working just fine.

 

Hope it helps.

Log in or register to post comments