Log in or register to post comments

XmlException: invalid data Error

September 24, 2017 - 10:49pm #1

I'm new to Unity (2017.2.0f1)  & Vuforia, got the basics working using a Mac & iPad2017, but I can't quite get a custom target working.  When I import the Unity Package downloaded from Target Manager, I get the following error:

XmlException: invalid data.

System.Xml.XmlStreamReader.Read (System.Char[] dest_buffer, Int32 index, Int32 count)

Mono.Xml2.XmlTextReader.ReadTextReader (Int32 remained)

Mono.Xml2.XmlTextReader.PeekChar ()

Mono.Xml2.XmlTextReader.ReadContent ()

Mono.Xml2.XmlTextReader.Read ()

System.Xml.XmlTextReader.Read ()

Vuforia.EditorClasses.ConfigParser.fileToStruct (System.String configXMLPath, Vuforia.EditorClasses.AuthoringInfoXmlProvider authoringInfoXmlProvider, Vuforia.EditorClasses.ConfigData configData)

Vuforia.EditorClasses.ConfigDataManager.ReadConfigData (System.String dataSetFilePath)

Vuforia.EditorClasses.ConfigDataManager.DoRead ()

Vuforia.EditorClasses.SceneManager.EditorUpdate ()

UnityEditor.EditorApplication.Internal_CallUpdateFunctions () (at /Users/builduser/buildslave/unity/build/Editor/Mono/EditorApplication.cs:127)

When I click "Open Vuforia Configuration", there are no choices under datasets.  I've also tried clicking add database, downloading the Package then importing into Unity, but that gives me the same error.

I've seen a few posts with the same XmlException error, but I can't get their solutions (editing the XML document settings in Notepad++ or Text Wrangler) to work.  None of those posts really had a definitive answer to explain what's going on.  Thanks for the help!

 

 

XmlException: invalid data Error

September 28, 2017 - 9:25am #3

Hello overman,

Could you please send me your dataset's unitypackage so I can try to import it in a project and test it myself?

Thanks,

-Vuforia Support

XmlException: invalid data Error

September 25, 2017 - 10:20pm #2

I'm getting the same error with a different 5-star Image Target, but now developing on a Mac with Unity 5.6 and Vuforia 6.2 as recommended by Vuforia support on another thread.  XmlException: invalid data.  Basically, I cannot import a package from Target Manager without getting this error.

Does anyone know if I'm doing something wrong?

Log in or register to post comments