Topic locked

Camera is not opened and screen is black with Vuforia 4.0 beta

February 19, 2015 - 11:01pm #1

Hi All,

We are trying to implement IOS native UI with Unity3d 4.6.2 using this reference (http://www.the-nerd.be/2014/08/06/add-unity3d-in-a-native-ios-application/) link.

We done the same with Vuforia 3.0.7 & Unity3d 4.6.2 , working fine.

But when we try with Vuforia 4.0 beta and unity3d 4.6.2, its not working. IOS native buttons are displayed but Vuforia Camera is not initialized. Showing black screen. How to solve this one? 

Can anyone tried?

It would be great if i get suggestions.

 

 

 

Camera is not opened and screen is black with Vuforia 4.0 beta

March 9, 2016 - 10:52am #10

UPDATE: Vuforia 5.5.9 has been released and supports the METAL Graphics API on iOS:

https://developer.vuforia.com/library/articles/Release_Notes/Vuforia-SDK-Release-Notes

https://developer.vuforia.com/downloads/sdk

Also, make sure to check the Unity Migration Guide before upgrading to Vuforia 5.5:

https://developer.vuforia.com/library/articles/Solution/Migrating-Unity-Projects-to-Vuforia-5-5

Camera is not opened and screen is black with Vuforia 4.0 beta

February 22, 2015 - 6:38am #9

@vamshi: glad to hear it works ;-)

 

@wagnall:

Had the same thing on Unity 4.6.3. Changing the Graphics API to Open GL ES 2.0 / 3.0 seems to get rid of the issue so that suggests it's something to do with the introduction of Metal support in Unity?

If you use the latest (current) 4.0.11 beta, and you import any of the Vuforia samples unity packages, the rendering settings should be automatically enforced and switched to OpenGL ES 2.0; 

 in any case, the OpenGL ES 2.0 (as of today) is the correct settings to use in Unity, so, if the rendering settings are not set to that,  then you'll need to manually set them to GL ES 2.0 in the Player Settings menu;  

the "Metal" graphics API is not yet supported by Vuforia at this time.

 

Camera is not opened and screen is black with Vuforia 4.0 beta

February 21, 2015 - 4:39am #8

Perfect !!!

Camera is not opened and screen is black with Vuforia 4.0 beta

February 21, 2015 - 4:30am #7

In Vuforia 4.0 you need to add the Vuforia namespace, i.e. add this line at the top of the script  :

using Vuforia;

 

Camera is not opened and screen is black with Vuforia 4.0 beta

February 21, 2015 - 1:51am #6

In Vuforia 3.0.7, To solve the black screen issue, we have manually used the below code for enable and disable AR Camera:

Disable AR Camera :

       CameraDevice.Instance.Deinit();
       CameraDevice.Instance.Stop();

Enable AR Camera : 

        CameraDevice.Instance.Init(CameraDevice.CameraDirection.CAMERA_BACK);
        CameraDevice.Instance.Start();
        CameraDevice.Instance.SetFocusMode(CameraDevice.FocusMode.FOCUS_MODE_CONTINUOUSAUTO);

Problem : 

I tried the same code in Vuforia 4.0 beta for enable/Disable AR Camera, but showing an error The name `CameraDevice' does not exist in the current context.

can anyone suggest ? 

It would be great, if i get quick solution.

Thank you,

vamshi

Camera is not opened and screen is black with Vuforia 4.0 beta

February 20, 2015 - 9:37am #5

I Had the same thing on Unity 4.6.3. Changing the Graphics API to Open GL ES 2.0 / 3.0 seems to get rid of the issue so that suggests it's something to do with the introduction of Metal support in Unity?

Camera is not opened and screen is black with Vuforia 4.0 beta

February 20, 2015 - 5:25am #4

yep that is exactly what I get when on iPhone 6 Pluse, but on iPad works fine?

Camera is not opened and screen is black with Vuforia 4.0 beta

February 20, 2015 - 5:07am #3

Hi, 

If i run the vuforia SDK with Unity, it wont create any problem and working excellent.

The problem is, when i integrate the same project with IOS native UI  (http://www.the-nerd.be/2014/08/06/add-unity3d-in-a-native-ios-application/), Camera is black.But the augmentation is working (have a look on attached image).

Can anyone help ? how to enable the camera ?

Thank you.

AttachmentSize
Image icon IMG_0818.PNG20.09 KB

Camera is not opened and screen is black with Vuforia 4.0 beta

February 20, 2015 - 12:10am #2

I'm using Unity Pro 4.6.3 and just discovered the Vuforia black screen exactly as you describe but only doing this for me on iPhone 6 Plus.  If I run the same project on iPad 4 the camera works fine.

 

Vuforia mods?

Topic locked