C'ant build unity Android project after vuforia 4 update/install

April 7, 2015 - 12:36am #1

Hello,

I'm working on unity 4.6.3 ..

I have several android projects on my machine, they build fine.

I had a vuforia 3 project which was working great, build fine and was working on android.

I updated to vuforia 4, the project is working fine in the inspector but it refuses to build, syaing that he can't locate JDK, it needs at least jdk1.7..

I have jdk 8,.. 

 

I also tried to create a new project without anything in it, install vuforia 4 and the android samples, build the image target scene and it has the same error messages.

 

Anyone got this error?

(here is the error log in the console : 

Error building Player: UnityException: Unable to find suitable jdk installation. Please make sure you have a suitable jdk installation. Android development requires at least JDK 7 (1.7). The latest JDK can be obtained from the Oracle 
 
)
 
thanks

C'ant build unity Android project after vuforia 4 update/install

April 10, 2015 - 11:02am #3

I had the same problem when i first tried building for android, basically it doesn't detect where your java folder is. For me fix was that i manually told it where the folder is. For me it was in appdata (search for %appdata% in windows explorer) and then find folder called Oracle. Appdata folder is hidden when you try searching for it with browse option it gives you, so you'll have to manually input the path which should be smthing like this: C:\\users\*your name*\appdata\roaming\oracle

C'ant build unity Android project after vuforia 4 update/install

April 9, 2015 - 12:38pm #2

Updating the Vuforia SDK in a Unity project shouldn't have any effect on your JDK installation. See the correct Vuforia migration steps here:

https://developer.vuforia.com/library/articles/Solution/How-To-Migrate-a-Unity-Project

For troubleshooting a Java installation, you might want to use Eclipse or Android Studio.

 

Log in or register to post comments