Semantic issue on QCARUnityPlayer

June 1, 2015 - 6:57am #1

I upgraded from Unity 4 to 5 and Vuforia 3 to 4 and now xCode complains when building for iOS.

It happens on the UnityAppController.mm

- (void)applicationDidBecomeActive:(UIApplication*)application{
	// Code

	QCARUnityPlayer::getInstance().QCARInit([orientation UTF8String]);
	QCARUnityPlayer::getInstance().QCARSetOrientation([_unityView contentOrientation]);
		[self performSelector:@selector(startUnity:) withObject:application afterDelay:0];
	}

	_didResignActive = false;
}
- (void)applicationWillTerminate:(UIApplication*)application
{
	//Code
	QCARUnityPlayer::getInstance().destroy();
	//Code
}

 

Semantic issue, Use of undeclared identifier 'QCARUnityPlayer'.

I do have the #include "QCARUnityPlayer.h" on the top.

I have tried to restart and rebuild but nothing changes. 

I have set the build to IL2CPP with ARM64 if that is relevant.

Anything missing or wrong?

Semantic issue on QCARUnityPlayer

June 3, 2015 - 8:03am #5

Thanks so much for that.

I did follow that guide but must have also missed that one file as I had the PostProcessBuildPlayer still there with an extra file with the 1 on it.

All seems to work and compile now.

Cheers

Semantic issue on QCARUnityPlayer

June 2, 2015 - 10:29pm #4

Hei,

 

in my case it was a file I did not remove:

PostProcessBuildPlayer

do a search in your project, it is likely that Vuforia added a second one with the same name and " 1" extension to it. You could remove the original and remove the " 1" extension but I would recommend to start fresh and follow carefully that page:

https://developer.vuforia.com/library/articles/Solution/How-To-Migrate-a-Unity-Project

Also, delate your xCode project as it is likely that those files are not rewritten if already existing.

 

Semantic issue on QCARUnityPlayer

June 2, 2015 - 8:42pm #3

Hi,

I have just run into the same issue.

Could you please explain what you did to solve this.

I'd be extremely grateful if you could.

Cheers

Semantic issue on QCARUnityPlayer

June 2, 2015 - 2:53am #2

Well, invoice comes faster than help so I solved it myself...I guess it is the point of waiting, the user will probably figure it out...

Log in or register to post comments