Log in or register to post comments

Vuforia 4.0 Scanlinefix.cs Issue

April 5, 2015 - 5:58pm #1

Hello ,

After solving the expanded GUI view by attaching the scanlineFix scipt to the AR camera .. i faced wierd issue .
Each time i try to scan a marker which have 3d object the screen become white and sometimes blue :

[With ScanLineFix Script]
Before Scanning :
https://developer.vuforia.com/sites/default/files/Screenshot_2015-04-06-03-17-22.png

After Scanning :
https://developer.vuforia.com/sites/default/files/Screenshot_2015-04-06-03-17-48.png

When i lose the marker the white screen dissapear and i go back to the scanning state :

When i remove the scanlinefix script i can see the Augmnted object without any problem but i got the expanded view issue back when i lose the marker only :
 

[Without ScanLineFix Script]
Before Scanning :
https://developer.vuforia.com/sites/default/files/Screenshot_2015-04-06-03-20-39.png

After Scanning :
https://developer.vuforia.com/sites/default/files/Screenshot_2015-04-06-03-21-17.png

Any one Can help ?

Thanks

Vuforia 4.0 Scanlinefix.cs Issue

August 4, 2015 - 10:09pm #8

moisestafolla... Thanks to your concern it was a problem with the bit.. I was using 64 bit Unity 5 and so it wasn't working. I downloaded the 32 bit version and it started working. Thanks to vuforia. :)

Vuforia 4.0 Scanlinefix.cs Issue

August 4, 2015 - 4:05pm #7

Which Unity version are you using? Is this happening in the sample apps? Have you tried with the latest Vuforia release?

Vuforia 4.0 Scanlinefix.cs Issue

August 2, 2015 - 12:50pm #6

I am too facing the same problem as Revereal.. The screen goes white as I bring it near the marker to scan.. otherwise a normal camera will work.  I dnt know what is wrong.. But surely there will be a fix.. So please if ANyone whould suggest something.. Thanks

Vuforia 4.0 Scanlinefix.cs Issue

April 17, 2015 - 3:20am #5

Vuforia 4.0.105 with support for Unity 5.0 has been released; this release should also fix the scanline issue (and you should no longer need to use the ScanlineFix script).

https://developer.vuforia.com/forum/news-and-announcements/announcing-unity-50-64-bit-support-mac-os-x

 

Vuforia 4.0 Scanlinefix.cs Issue

April 14, 2015 - 3:21am #4

Ok, thanks for confirming.

Meanwhile,

we  expect to release an updated release of 4.0 very soon, which should also include a native fix for the scanline issue,  so that you will no longer need to use the "ScanlineFix" script as a workaround in Unity;

That should solve your issue without requiring any additional workarounds.

This is expected very soon (stay tuned and bear with us in the next days...)

 

Vuforia 4.0 Scanlinefix.cs Issue

April 13, 2015 - 6:09am #3

Thanks for your reply ..

yes i attached this script to the camera object under AR camera

Vuforia 4.0 Scanlinefix.cs Issue

April 10, 2015 - 4:39am #2

Hi,

have you attached the ScanlineFix script from here:

https://developer.vuforia.com/forum/unity-3-extension-technical-discussion/vuforia-40-and-unity-50

?

This is supposed to be attached to the Camera object under the ARCamera in Vuforia 4.0; if you attached it to the ARCamera itself, you should remove it from ARCamera and attach it to the child Camera object;

have you tried that already ?

 

Log in or register to post comments