Topic locked

Vuforia 5.0.10 + Unity 5.3.1p1

December 29, 2015 - 9:44am #1

Hi, Unity just released the 5.3.1 p1 (patch).

This version builts with the Bitcode for iOS, which is great.

Unfortunately it doesn't build because Vuforia doesn't have Bitcode yet, even if I set bitcode enabled=NO, it doesn't build.

At the moment its not that important but looks like that from now on Unity will use bitcode and therefore if Vuforia doesn't support it I can't build my apps on iOS.

 

Is there any news about it on Vuforia side?

 

Thanks

Ale.

Vuforia 5.0.10 + Unity 5.3.1p1

January 4, 2016 - 6:13am #6

Great.

Vuforia 5.0.10 + Unity 5.3.1p1

January 4, 2016 - 1:53am #5

Hhi AlessandroB, yeah it was Unity! I removed it, download it again and reinstalled it, now works.

Not sure why this happens, it already happened a few months ago with an older version.

 

Anyway, thanks for the support!

 

Cheers,

Ale.

Vuforia 5.0.10 + Unity 5.3.1p1

January 1, 2016 - 10:21am #4

Before reinstaling Unity, you may want to check that you have correctly disabled Bitcode in BOTH the Target AND the Project, as shown in the attached screenshots.

Then make sure to also "Clean" the project and "Build" again.

If noting works, maybe you need to reinstall Unity 5.3.1p1 

 

 

AttachmentSize
Image icon Bitcode_settings_2.png39.19 KB
Image icon Bitcode_settings_1.png29.91 KB

Vuforia 5.0.10 + Unity 5.3.1p1

January 1, 2016 - 10:01am #3

Hi AlessandroB, not sure waht's going on here, If I build using Unity 5.3.1f1, no problem, if I build using Unity 5.3.1p1, it doesn't build.

I set the bitcode to NO but I get 1 error saying the Vuforia doesn't contain bitcode.

 

Maybe worth trying to remove Unity and reinstall it again, that's clearly something odd here.

Thanks!

 

Vuforia 5.0.10 + Unity 5.3.1p1

December 30, 2015 - 6:14am #2

 "...even if I set bitcode enabled=NO, it doesn't build...."

You might have set the bitcode option incorrectly in Xcode;

if you select your Project and Target in Xcode, and you set ENABLE_BITCODE to NO, then you should be able to rebuild your Xcode project and run it on your iOS device.

I've tested this with Unity 5.3.1p1 and Xcode 7.2, on an iPhone 5S with iOS 9.2, using Vuforia ImageTargets sample 5.0.10; after disabling bitcode, it just compiled and ran without problems.

 

Topic locked