Log in or register to post comments

[SOLVED]marker childs moving away from the marker - Can anybody explain this video

March 22, 2018 - 6:11am #1

I am working on a AR project basing on marker based AR method.I am using Unity-5.4.3f1 and Vuforia version is 6-1-17 and Its initial working is fine.It is loading faster,showing all the animations for while.After some time of nice play,the marker childs are moving away from the marker.As per the suggestions from Vuforia team,I put the marker over a textured background.Even then It is not showing consistency.Another work also havng the same problem.This sample I posted as an examle.

 

I am attaching a video to show the displacement of the children from the marker.

P.S:I am already using OnTrackingLost() and OnTrackingFound() methods of "ITrackableEventHandler" interface.Can anybody solve this problem?

AttachmentSize
Package icon app_drifting_bug_video.zip12 MB

[SOLVED]marker childs moving away from the marker - Can anybody explain this video

March 22, 2018 - 10:58pm #2

After so much R&D into Vuforia setttings, I have solved the shaking/drifting of marker children.

 

My own error is:While developping the project step by step somewhere I added smartt terrain,bt after removing it I forgot to uncheck "smart terrain tracker bhaviour \" script from AR Camera.I have teted it with a testing ap and finally removed it.

I have removed "default initialization error Handler" script also from ARCamera Panel.

I have unchecked Enable Device Pose Tracking checkbox



P.S:with all these updates my Apk is behaviour is stable now ven without any textured backgriound.But If I have encountered in my testing  - I will put the marker on a texture or pattern.

Log in or register to post comments