Log in or register to post comments

Target Scanning gets failure randomly even for 5 star image with good lighting condition.

February 13, 2019 - 6:02am #1

Even though we have good light atmosphere, Image rating in 5 and wifi is connected.



While doing scanning, either scan gets failure (keep on scanning, no response) or if scanned content is loading, its not loading on the top of the target (loads some where).



Please advice how to achieve successful scanning followed by loading of content on the exact target.

Target Scanning gets failure randomly even for 5 star image with good lighting condition.

February 13, 2019 - 11:44am #2

Hello,

The star rating provides a heuristic analysis of the given target, but does not necessarily represent the actual run time detection and/or tracking performance. It is to provide some level of feedback to help guide developers to optimize their targets.

Here is some guidance on optimizing targets: https://library.vuforia.com/articles/Solution/Optimizing-Target-Detection-and-Tracking-Stability

Some additional tips:

  1. Always print the image that was uploaded to the portal to the exact same aspect ratio. Any stretching or altering of the image may cause tracking pose jitter. Some printers default to "stretch to fit", which can change the aspect ratio.
  2. Check the size values you are using when uploading Targets to the Vuforia Target Manager. Note there is specific language used in the dialogue box that says Vuforia uses meters as the default unit scale. Incorrect target sizes could affect either our detection/tracking algorithm
  3. Image Targets must be flat when in the camera's field of view
  4. Not enough lighting upon, and/or spectral reflections occluding the Image Target

Thanks,

Vuforia Engine Support

Log in or register to post comments