Log in or register to post comments

Vuforia API 500 Error

June 21, 2021 - 11:14pm #1

Hello. We are getting problem with Vuforia API, to uploading markers into Cloud based database. 

When we uploading marker image using API call, we are getting 500 Server Error.  But the same marker is uploading without any problem from target Manager. 

This is happening only few times(not for all marker). 



Here is marker specifications: 

Resolution - 1180x1775 (96dpi)

Name - HEXY5lM3TyOnLl0C.jpg

Size - 385Kb 

Bit depth 24



We are not getting any message about the reason. Please help to understand what is the problem?

Vuforia API 500 Error

August 12, 2021 - 11:42pm #6

Yes it is very strange. same image wihout any changes can be uploaded via developer portal. 

but with api call  it give 500 error. 

I will be able to provide the call function code later today.

Vuforia API 500 Error

August 12, 2021 - 8:39am #5

Hello,

looking on the picture - it contains different gemetrical solids / prmitives in a table and text. Is the  whole picture (text with table and pictures of solids) the target or only the pictures for specific gemetrical solid ( prism ) is used as target?

Another point is that according to  https://library.vuforia.com/articles/Training/Cloud-Recognition-Guide.html

"The Target Manager and the VWS API both support planar, 2D Image Targets with Cloud Recognition. Images used for Cloud Recognition must be either 8-bit or 24-bit PNG or JPG formatted files. JPG files must be RGB or greyscale. Images with the alpha (transparent) channel are not accepted. The maximum image file size is 2.25 MB."

If this image is the used picture it is 204 KB< 2.25 MB - is OK and 24 bits per pixel and RGB so far I do not see why this should not work. Possibly some random issue. Need to verify if this picture always raises an error in th VWS call

Best Regards

Vuforia API 500 Error

August 12, 2021 - 1:41am #4

Hello. Sorry for late reply.  

here is an image that is not passing vuforia "control" with API call. 

AttachmentSize
Image icon hZjRgBKJfvD1IWoa.jpg223.71 KB

Vuforia API 500 Error

June 25, 2021 - 6:25am #3

The issue happening on specific images(no idea what is difference).  I will send you one of them when will get that problem again. 

 

Vuforia API 500 Error

June 24, 2021 - 5:51am #2

Hello,

the error 500 - general https status :  https://developer.mozilla.org/en-US/docs/Web/HTTP/Status/500 and according to the dev. portal article How To Use the Vuforia Web Services API (last document table) is an general server issue so that it does not give to significant information so that e.g. some error on the request or usage of the wrong server key could be the reason.

Does  the issue occur with specific object or is general behavior when you try to upload an image target to the data cloud?

I tested the issue using java Cloud examples  -> (zip file with all java samples ) and used the PostNewTarget.java (modified to work for my test cloud database)

It was working fine. So I think it will be good idea if you try with this test to see if it will work

Important is to check the access keys here

//Server Keys

    private String accessKey = "6adadxxxxxxxxxxxxxxxxxxxxxxxxxxxxxcdda152";

    private String secretKey = "893340xxxxxxxxxxxxxxxxxxxxxxxxxxxx84de94b";

   

    private String url = "https://vws.vuforia.com";

    private String targetName = "TestTarget";

are used correctly from your dev portal account:

 

So here the modified version of the java code which uploaded 4 image targets and set the size - please, check the attached PostNewTargets.pdf file

BR

aVuforia Engine Support

AttachmentSize
PDF icon PostNewTargets.pdf38.97 KB
Log in or register to post comments