VUFORIA_SENSOR_FUSION

April 1, 2021 - 3:27am #1

Hi 

I'm trying to force Vuforia to use VISLAM for Ground Plane. 

I'm calling this method in Awake() : VuforiaRuntimeUtilities.SetAllowedFusionProviders(FusionProviderType.VUFORIA_SENSOR_FUSION); 

Strangely, it is forcing towards VUFORIA_VISION_ONLY. 

In fact, when i call VuforiaRuntimeUtilities.GetActiveFusionProvider() i get VUFORIA_VISION_ONLY, and can't use Ground Plane anymore. 

 

Why is it happening ? 

 

Thanks in advance 

Log in or register to post comments

Vuforia is inverting blue colour with red and red with blue in the app

March 12, 2021 - 3:03am #1

Vuforia SDK Version: 9.7 -

Description with steps to reproduce: I created 2 AR apps using Vuforia in Unity but both exhibit a bug where the red and blue colours when viewed through the camera get inverted into blue and red respectively. Any help is appreciated. Original Image: https://ibb.co/QN63F1w AR App Image: https://ibb.co/W0ZNL8X -

Development OS (Mac OS X, Windows, Linux): Windows 10 -

Mobile OS and Version: Android 11 -

Log in or register to post comments

no se puede cargar destino

March 9, 2021 - 7:24pm #1

buenas noches, 

apenas voy a cargar la imagen me aparece un mensaje que dice que no se puede cargar el destino, y como soy nuevo en esto pues no entiendo porque, alguien me podria ayudar.

  

Log in or register to post comments

Vuforia image detection works on webcam but not on iOS device

February 18, 2021 - 3:50pm #1

Hello, so basically as the title says, I am able to get my vuforia running just fine when I run the application on a simulation on my pc or mac. However, when I build it for my iOS device and open the application on my phone, the vuforia camera shows video but it never detects my image. Any though on this?



I thought it was because I did not enable the vuforia in my xr settings under player but I do not have that option. After some research it says that you no longer have to do that step. So what could be wrong here?

Log in or register to post comments

Webcam Not Working

February 14, 2021 - 3:44pm #1

Hy guys,

i got a problem that making me confused about the AR.

i already installed Vuforia from the package manager of Unity 2019.4.20f1.

i set up my configuration... just like the YT tutorial does, but my Laptop's webcam still not working.

i have tried it in several laptops and it's the same.

did i do it incorrectly or anything else?

please help me.

Log in or register to post comments

png file image targets do not work at runtime for Unity Editor Play Mode

February 9, 2021 - 9:12pm #1

Vuforia SDK Version: 9.7.4 -

Description with steps to reproduce: I followed the steps as described here: https://library.vuforia.com/articles/Solution/how-to-create-and-load-targets-in-unity.html

I used this plugin to load images from file: https://github.com/yasirkula/UnityNativeGallery
Specifically, I used

Log in or register to post comments

only astronaut works..?

January 28, 2021 - 11:41pm #1

Vuforia SDK Version: latest -

Description with steps to reproduce: im having a issue where if i use the astronaut image and use a custom mesh the astronaut still appears on my android build.
And if i use a custom image and mesh it just doesnt work.
they work fine over webcam but when i build it thats what happens.
im using the free license as i wanted to test and build a app but i can only do this over webcam ? -

Development OS (Mac OS X, Windows, Linux): windows -

Mobile OS and Version: andriod -

Log in or register to post comments

Nullpointer when using delayed initialisation

January 27, 2021 - 6:23am #1

Vuforia SDK Version: 9.6.x -

Description with steps to reproduce: Hello,

Using 9.6.4 in unity, this happens when trying to delay initialisation:

NullReferenceException: Object reference not set to an instance of an object.
at Vuforia.UnityRuntimeCompiled.ARFoundationIntegration.OpenSourceUnityARFoundationFacade.FindDependencies () [0x00000] in :0
at Vuforia.ARFoundationARController.InitializeForARFoundation (System.Action`1[T] onComplete) [0x00000] in :0

Steps to reproduce:

Log in or register to post comments

No 'git' executable was found

January 14, 2021 - 3:03pm #1

Vuforia SDK Version: 9-6-4 -

Description with steps to reproduce: Hi there,

Today i tried to instill for the fist time Unity and Vufora but i had problem doring it:

"
An error occurred while resolving packages:
Project has invalid dependencies:
com.ptc.vuforia.engine: No 'git' executable was found. Please install Git on your system then restart Unity and Unity Hub

Log in or register to post comments

Unable to import Vuforia 9.6.4 to Unity

December 22, 2020 - 12:25pm #1

Vuforia SDK Version: 9.6.4 -

Description with steps to reproduce: Vuforia 9.4 worked just fine for me, and I faced no issue installing it into Unity 2019 and Unity 2020. But, after lots of efforts, I am unable to install/import Vuforia 9.6 into Unity. It shows 'Resolving Packages' and runs infinitely. It happens in both Unity 2019 and Unity 2020. Now, I'm unable to use Vuforia at all. Please solve this issue and try to provide older versions of Vuforia as well. -

Development OS (Mac OS X, Windows, Linux): Windows 10 -

Log in or register to post comments