Topic locked

Android 5 (Lollipop) Bug?

November 30, 2014 - 6:03pm #1

Hi,

I have an app that has successfully integrated Vuforia and it works great on phones running Android 4.4 and below. Today I updated a couple of my dev phones to Android 5 Lollipop and all of a sudden, Vuforia no longer works. The error I receive when the user navigates to the Vuforia screen is:

"the library libvuforia.so could not be loaded"

My build works fine in previous versions of Android, so I don't think that other forum posts related to this error message necessarily apply to what is happening to me. Also, I have upgraded to the latest Android NDK (r10c) and am using gradle to build my app.

Is this a known issue with Android 5? Can anyone get Vuforia to work on Android 5?

Thanks!

 

Android 5 (Lollipop) Bug?

December 2, 2014 - 2:27am #7

Glad to hear ;-)

Note that this might be more due to the fact that you upgraded to NDK R10c (rather than Android 5), as you mentioned in your first message. 

Anyway, glad it is sorted.

 

Android 5 (Lollipop) Bug?

December 2, 2014 - 12:25am #6

Hi Alessandro, 

It looks like that fixed it! Thanks for your help. Including libVuforia.so in armeabi-v7a worked. It is interesting the leaving it in armeabi worked for earlier versions of Android.

Thanks!

Android 5 (Lollipop) Bug?

December 1, 2014 - 9:48am #5

Normally the libVuforia.so should end up into the 'armeabi-v7a' folder inside your APK package; the fact that you get it in 'armeabi' (and not in 'armeabi-v7a') sounds suspicious; the problem might be in there.

if you have another device still on Android 4.4, could you build your Gradle project on such device and see if you get the libVuforia.so stored into the 'armeabi-v7a' folder in the APK ?

 

 

 

Android 5 (Lollipop) Bug?

December 1, 2014 - 8:17am #4

Perhaps, this might help get to the right answer. I just unzipped the APK file that is produced for both versions (4.4 and 5.0) of Android. It contains a lib folder. The lib folder contains a number of subfolders:

arm64-v8a,

armeabi,

armeabi-v7a,

mips,

mips64,

x86,

x86_64,

The subfolders all contain the .so file for my project (libMyProject.so). But only the armeabi folder contains libVuforia.so. Is this correct? Should libVuforia.so be replicated in as many places as my project's .so file? Might the Nexus 5 running Android 4.4 access one of these folders while the Nexus 5 running Android 5.0 accesses another?

Thanks!

 

Android 5 (Lollipop) Bug?

December 1, 2014 - 8:07am #3

Hi Alessandro,

Thanks for your quick reply!

We are using Vuforia 3.0.5.0. Also, all of our builds are happening automatically via Gradle on the command line. So I can interleave building for Android 4.4 and Android 5.0 and the 5.0 build always fails to copy the file and the 4.4 build always succeeds. It does seem like we are not copying the library over, but there should not be any difference in the way the script builds the app. But I will investigate this further.

Interestingly enough though, the dev phone we are using is a Nexus 5! So that might be part of the problem. Vuforia works for us on the Nexus 5 running Android 4.4 though. I will try on a different device. Can you let me know what devices you have successfully test Vuforia and Android 5 together?

Cheers,

Philipp

 

Android 5 (Lollipop) Bug?

December 1, 2014 - 12:54am #2

If you are using the latest SDK 3.0, Vuforia should just run fine on Android 5; at the moment there is a known issue when using Nexus 5 (dark camera in certain conditions), but nothing related to the error you mention here:

the library libvuforia.so could not be loaded

This error message is just saying that you probably did not export the Vuforia native library onto your device. This is usually just depending on some project configuration issue  or you might have re-built the library but forgot to refresh your project in Eclipse or Android Studio. 

What version of Vuforia are you using ?

 

 

 

Topic locked