Log in or register to post comments

ODG R7 + Unity 2017.2.0f3 + Vuforia

November 13, 2017 - 1:37am #1

Hi! It's first time I write, I have a problem with my ODG R7 (updated with last Reticle OS), Vuforia (6.5.25 in Asset Store of Unity App) and Unity 2017.2.0f3.

I can't see fine 3D objects, is like the field of view is not correct or glasses is rendering wrong.

Is like right image is in left position and left image in right position...

I did a capture about what I'm watching and image is right, but when I see it in glasses is strange.

 

 

Any solution?

AttachmentSize
Image icon screencap.png134.31 KB

ODG R7 + Unity 2017.2.0f3 + Vuforia

February 28, 2018 - 3:50am #11

it15139 wrote:

Same problem here...I am using same version of Vuforia together with Unity 2017.3.0f3 and latest version of ReticleOS and deactivated multithreaded rendering. Also the Vuforia samples, I can cownload from the unity asset store, show the same problem.

Hi I started this post, and I quote you if service send you a message of quote.

I updated the Reticle OS (to last version in glasses configuration), I updated "Vuforia Stereo Rendering for Digital Eyewear" plugin from Unity 2017.3.0f3 (64-bit) to 7.0.47 version.

(I downloaded the plugin in the Unity store, not from web page).

Then in:

              "Player Settings"->"Other Settings" I disable "Multithreaded Rendering"

              "Player Settings"->"XR Settings" I activate "Virtual Reality Supported" and selected "Vuforia"



I built an APK and it works!

So I calibrate again the camera with "Vuforia calibration" and it works. I can't believe it.

 

So this post we can close it.

Thank you.

Best regards.

Alejandro Oliver

Virtual Reality Department

vr2@vistadiferent.com

www.vistadiferent.com

ODG R7 + Unity 2017.2.0f3 + Vuforia

February 22, 2018 - 11:04am #10

Hello all,

It has come to our attention that some users are attempting deployment workflows that are not officially supported by Vuforia. When deploying your app with a Unity project, please deploy directly from Unity. Exporting the Unity project into Android Studio and then building and deploying the app there is not a supported workflow and may result in issues with your app.

Additionally, if you were previously working in an older version of Vuforia (pre-7.0) and have upgraded your project to Vuforia 7.0.X, please run the user calibration again. The older calibrations (such as those done with Vuforia 6.5.X) are not compatible with Vuforia 7.

Please let me know if you have any questions related to this.

Thanks,

Vuforia Support

ODG R7 + Unity 2017.2.0f3 + Vuforia

February 14, 2018 - 11:53pm #9

Same problem here...I am using same version of Vuforia together with Unity 2017.3.0f3 and latest version of ReticleOS and deactivated multithreaded rendering. Also the Vuforia samples, I can cownload from the unity asset store, show the same problem.

ODG R7 + Unity 2017.2.0f3 + Vuforia

February 5, 2018 - 4:15pm #8

Hello Mark,

Could you provide more information on some settings and versions used in your tests with Unity? We just tested and confirmed correct behaviour in the Stereo Rendering Unity sample using Unity 2017.3.0p4 which contains Vuforia 7.0.47. The ODG OS version was 4.2.5. Which versions did you use for all of this?

Also, can you please confirm that Multithreaded Rendering is not checked in your Android Player Settings -> Other Settings.

Thanks,

Vuforia Support

ODG R7 + Unity 2017.2.0f3 + Vuforia

February 3, 2018 - 8:31am #7

Following up on a resolution for this issue? 

I am evaluating the ODG R7 for a few field apps we built in Unity 3D. If I downgrade project to Unity 5.6.x it renders stereo fine. IF I use the project in Unity 2017.x <choose your flavor> I still see the monoscopic rendering across both eyes. Left on left... cut half and then right on right. There is no Stereo rending happening at the runtime. I have flipped all the check boxes for Vuforia and XR Settings. Still not seeing a difference. Could it be that the Unity Runtime for Vuforia needs to have a eyeware profile corrected or added? It acts like even with flipping the options for digital eyeware to stereo it does not detect it at runtime correctly. 

I am sad to remove this device from my Eval of Vuforia for Enterprise. It kinda sad that Wikitude, EasyAR, and ArToolkit work fine, but Vuforia has this rendering issue still at runtime.

I am aware it appears to not be an issue in the Java runtime (Android studio), but my eval is based on Unity3D product development workflows.

I am also going to chase this with my direct rep with PTC.

-Mark 

ODG R7 + Unity 2017.2.0f3 + Vuforia

January 31, 2018 - 9:35am #6

Did anyone solve this problem? I'm facing the same issue with an ODG R7 and Unity 2017.3.0f3

ODG R7 + Unity 2017.2.0f3 + Vuforia

November 21, 2017 - 9:42am #5

@BierroNrec

Yes, I selected Virtual Reality supported and Vuforia in XR Settings.

ODG R7 + Unity 2017.2.0f3 + Vuforia

November 21, 2017 - 7:50am #4

Hey sukifree,

Have you checked "Virtual Reality supported" and selected Vuforia in the XR Settings?

ODG R7 + Unity 2017.2.0f3 + Vuforia

November 15, 2017 - 12:28am #3

Hi! Thanks for reply. Yes, I tested disabled and enabled "Multithreaded Rendering" and pass the same.

 

Edit:

The first problem we think is that the ODG was not updated, so we installed a version that support technicians passed us (4.2.4 beta Reticle OS), however with the Unity application it still did not work correctly and with Android Studio it works perfectly (Vuforia).



The ODG technicians have told us that it is no longer their problem and that problem lies in Vuforia.

It has been tested since Unity version 2017.1.0f3, 2017.2.0f3 until the beta version 2017.3.0b9 and it does not work correctly (with the versions of Vuforia 6.0.23, 6.0.25 and Unity beta version)

The "Vuforia Stereo Rendering for Digital Eyewear" pack has been downloaded and we are working with it.

To compile in Unity the demos of Vuforia is deactivated in PlayerSettings: Multithreaded Rendering; We set "Device Filter" to "ARMv7", deactivate "Android TV Compatibility" and activate the option of Vuforia Augmented Reality in XR Settings.

Of course, I checked Eyewear type in ARCamera was in "Optical-See-Through" and See Through Config in Vuforia.

If a active "delayed initialization" in Vuforia Configuration and show any object in the scene glasses normal, but if I active it when charge it's impossible to see correctly.

Could it be that someone made me a guide for these glasses? Testing with Hololens, Moverio BT-300 and mobiles, Vuforia works correctly in Unity but not in ODG R7.

I do not know what else to explain or say. Any solution to this problem? Include can you send me a Unity project prepared to compile to ODG R7 glasses?

ODG R7 + Unity 2017.2.0f3 + Vuforia

November 13, 2017 - 4:57pm #2

Hello sukifree,

Do you have "Multithreaded Rendering" enabled in Player Settings -> Other Settings -> Rendering (for the Android build)? If so, you'll need to disable this as it is likely the cause of this issue.

Thanks,

-Vuforia Support

Log in or register to post comments