Log in or register to post comments

HoloLens recognizes ImageTarget but no holograms show up

October 23, 2018 - 1:36pm #1

I originally tried to create an app for the HoloLens in which it would detect an ImageTarget and I could interact with a menu to choose from a series of images to overlay on top. I added a UI "status text" which would tell the user whether the ImageTarget was found or not. When I deployed it to the HoloLens and tested it, everything worked except for the holograms I wanted to overlay, and the status text would correctly indicate whether the ImageTarget was being tracked. I then simplified my app to the same ImageTarget but with a single sphere overlaid on top of it. The same problem persisted; I could not get the sphere to show up. I then tried the simplified app just with the Unity Editor and a webcam, and it worked completely fine. Is this a problem with HoloLens compatibility or with some error in my build or scene settings that I am unaware of?

Scene Setup:

>HoloLensCamera (Default settings from HoloToolKit)

>ARCamera (Default settings from Vuforia)

>ImageTarget (Width of 0.12, Height of 0.1137, everything else default from Vuforia)

    >Sphere (Scale of 0.5 for all, Position of 0.3)

 

Player Settings (Windows):

Other Settings:

  • Scripting Runtime Version: .NET 3.5 Equivalent
  • Scripting Backend: IL2CPP

Publishing Settings:

  • Internet Client, Microphone, Webcam, and SpatialPerception checked off

XR Settings:

  • Virtual Reality Supported (Windows Mixed Reality)
  • Vuforia Augmented Reality Supported

 

Vuforia Configuration:

  • CAMERA_DEFAULT
  • Digital Eyewear - HoloLens
  • Track Device Pose - Optimize for ImageTargets and VuMarks

 

Any help would be appreciated. I have been trying to fix this problem for a while now and have found no solutions online.

HoloLens recognizes ImageTarget but no holograms show up

June 25, 2021 - 2:44am #6

Hello,

Please, check the setting according to the article :Working with the HoloLens Sample in Unity  There you can find the info how to use the example or how to setup a new scene.

But I think the best /easiest approach will be to create a new project, to load the HoloLens Assets  and  to open the scene   Assets\SampleResources\Scenes\2-ImageTargets

Please, test first if the project could be started on your device and if it works with the provided demo ImageTargers  Assets\Editor\Vuforia\ForPrint\ImageTargets

As next step you import your ImageTargets database and adapt the Image Targets and the augmentations / child of the ImageTarget elements. For additional image targets you could duplicate some of the existing ImageTargets

BR

Vuforia Engine Support

AttachmentSize
Image icon 2021-06-25_10-35-15.jpg425.92 KB

HoloLens recognizes ImageTarget but no holograms show up

June 24, 2021 - 11:26pm #5

Hey, I had a similar issues initially that the Hololens didn't activate the camera.

Make sure that the camera is active on the Hololens, after you started your app. a small white led should be active next to the camera indicating its active status. My apps don't ask for camera permission and I had to manually allow them in the Application settings. 

Go to Settings->Applications->Your Application check Camer a permission on

HoloLens recognizes ImageTarget but no holograms show up

June 24, 2021 - 6:59pm #4

Do you get the solution? I face the same problem and no solution come up.. :(

HoloLens recognizes ImageTarget but no holograms show up

January 15, 2019 - 7:19am #3

 I tryed to tag ARCamera as MainCamera. But my HoloLens still didn't turn on the camera.

 

HoloLens recognizes ImageTarget but no holograms show up

October 24, 2018 - 10:37pm #2

You don't need two cameras in your scene, just add the Vuforia scripts to the HoloToolkit camera and tag it with "MainCamera".

Make sure your AR objects are on a layer, that is actually rendered by a camera.

The near clipping plane is (per default) quite far away from the camera so maybe your objects are too close to the camera to be rendered. Adjust the distance of the near clipping plane accordingly.

Log in or register to post comments