Log in or register to post comments

Still an offset of augmented objects on HoloLens

June 18, 2019 - 8:04am #1

There's an issue with vuforia objects being augmented with an offset of where they're supposed to be on HoloLens. The object isn't flipped, but it moves opposite to how I move (to the right if I look left, forward if I get closer to the target, etc).

This was supposedly fixed as of Vuforia v8.1.10, under Bugfixes it states "Fixed an issue where an offset was added to trackables if a scene was additively loaded on HoloLens."  Found Here:  https://library.vuforia.com/articles/Release_Notes/Vuforia-SDK-Release-Notes.html

There's no mention of this in the latest update notes under known issues or bugfixes, so Vuforia appears to think the problem is fixed, but I'm still having this issue.

I'm using the latest version of both vuforia and Unity. I've tried everything. I followed the instructions Vuforia gave exactly. Found Here: https://library.vuforia.com/articles/Training/Developing-Vuforia-Apps-for-HoloLens .

My AR Camera is at position 0,0,0 and its tagged as the main camera. I've tried changing the clipping planes, I've measured my target image and put it in as meters very precisely, nothing has worked. I have "Track Device Pose" on so extended tracking is on.

Run in Background is disabled, Landscape Left is the only orientation checked, Vuforia supported is checked, and the Windows MR SDK. I've included a screenshot of the Build Settings and other settings. Quality is set to very low. I build it with "Release, x86, Device" in Visual Studio.

I've even tried adding the Mixed Reality Toolkit and deleting the MR Camera and replacing it with the ARCamera, and adding the MRTK scripts to it. (Yes, tagged as main camera and at 0,0,0).

I've been about as detailed and thorough as I can with this.

I've found posts of people who have fixed this before, but the solutions are outdated. Has someone dealt with this recently? Please help!

 

AttachmentSize
Image icon buildsettings.PNG94.45 KB
Image icon otherSettings.PNG102.08 KB

Still an offset of augmented objects on HoloLens

June 20, 2019 - 8:45am #2

Hello,

If you're observing that the position of your augmentation is not matching the expected camera movements during tracking, be sure to check the size of your printed targets. For optical see-through devices (such as HoloLens), the printed target must match the dataset's target size exactly, as uploaded to the Target Manager. Recall that the Target Manager works exclusively in the units of meters.

This differs from 2D planar targets on video see-through devices (mobile phones, tablets) where the aspect ratio of the printed target must match what was uploaded to the Target Manager (and is in your dataset).

Thanks,

Vuforia Engine Support

Log in or register to post comments