Log in or register to post comments

Can not parse? why?

March 1, 2016 - 8:54pm #1

So here's the version of my software

Unity 5.1.3 (32-bit) - as I follow the forum and got the answer that Vuforia 5 doesn't support on Unity 64 bit yet

Vuforia 5.0.10 - the latest version

 

here are my steps

1.Build a new project

2.import Vuforia unity package

3.switch to IOS platform

4.Export to empty folder

5.try to open the .xcodeproj file with Mac

then It gives me the message "xcodeproj cannot be opened because the project file cannot be parsed"

 

I guess this must be a stupid rookie mistake I make

this is my first time export to IOS though

Can not parse? why?

June 22, 2018 - 12:31am #15

thanks! you are my hero!! 

Can not parse? why?

June 2, 2018 - 1:40am #14

Hi AAKLebanon,

I am facing the same problem. Isit the issue solve?

Thanks.

Can not parse? why?

April 22, 2018 - 7:02am #13

https://library.vuforia.com/articles/Solution/Vuforia-Supported-Versions

 

in this link, I though it was very clear that Windows 10 is supported to build for iOS, but now I noticed that it is not. 

I have a slow internet here, I downloaded unity and iOS plug-in, and now you told me that I should download the mac version again, only to be able to build for iOS !! I don't have a mac, I build my project on my PC and bring my friend mac to copy my project to it... so my life is hard and you make it harder ...

Can not parse? why?

November 21, 2017 - 11:30am #12

Hello,

Please refer to my response on this thread: https://forum.unity.com/threads/xcode-project-generation-bug-in-windows-please-fix-it-in-the-next-version.505199/

Thanks,

-Vuforia Support

Can not parse? why?

November 18, 2017 - 8:47pm #11

I know where is the bug now.

In the Vuforia.UnityExtensions.Editor.dll, there is a class named PostProcessBuildPlayer in the namespace Vuforia.EditorClasses.

There's a line hard code like below. The bug is caused by it.

private static void ProcessPbxProj(string xCodeProjFileName, PostProcessBuildPlayer.Framework[] frameworks, PostProcessBuildPlayer.ResFile[] resFiles)

{

                    //...

                    streamWriter.BaseStream.Seek(-3L, SeekOrigin.Current);

                    //...

}

The bug is caused by the NewLine of win and mac is different. It should be coded like this instead.

streamWriter.BaseStream.Seek(-2L - (long)Environment.NewLine.Length, SeekOrigin.Current);

Please fix it in the next version.

 

 

Can not parse? why?

October 23, 2017 - 10:30am #10

Could you provide a link to the support page you are referring to AAKLebanon?

Thanks,

-Vuforia Support

Can not parse? why?

October 22, 2017 - 1:39pm #9

Is anyone solved this problem ? according to the support page, it seem that building xcode from windows is supported .

Can not parse? why?

June 29, 2017 - 9:00am #8

my happiness lived only for short time as it now coming with following error

Command /bin/sh failed with exit code 2

and the build fails exactly due to the same thing which causes the parse error to fix. So it solved one error but got into another

Can not parse? why?

June 29, 2017 - 8:40am #7

Worked like a dream. Thanks you so much.

Was making me mad to get the parse error.

Can not parse? why?

January 16, 2017 - 7:55am #6

Hi:

 

Today, I've been facing this problem (Unity Ver. 5.5 Windows Based system).

When I try to open my windows exported iOS project, i got "(..)the project file cannot be parsed". So, I decided to explore the project file, located in:

<Project path>/Unity-iPhone.xcodeproj/project.pbxproj

It is a plain text file, so you can use any text editor.

I found a line with a mismatched  quotes. It was:

shellScript = "\"$PROJECT_DIR/MapFileParser.sh\""\nrm -rf \"$TARGET_BUILD_DIR/$PRODUCT_NAME.app/Data/Raw/QCAR\"";

You can see the error with the yellow background color

To fix the problem, just remove the quotation mark and it will be parsed correctly in xCode.

Good luck!

Can not parse? why?

March 6, 2016 - 7:35pm #5

Glad you solve the problem as well.

I solved it by borrowing my friend's Mac,

and I just put my project from Windows to Mac only for build.

It has some cupple of warnings but It work anyway

Can not parse? why?

March 5, 2016 - 7:04am #4

I struggled from the same issue.  :-(   Wonder a lot why there is no hint in the vuforia documentation!

I assume that’s related to PostProcessBuildPlayers? If yes is there a solution to get a workaround? Using PostProcessBuildPlayer with unity under windows is decribed her but I have no Idea if this is the right way….  http://docs.unity3d.com/430/Documentation/Manual/BuildPlayerPipeline.html

Can not parse? why?

March 2, 2016 - 9:33pm #3

Thank you for your reply,

This has bother me for a long time

so this always won't work out right?

nothing related to Vuforia version 

 

Can not parse? why?

March 2, 2016 - 7:49pm #2

Building a Vuforia iOS project from the Windows version of Unity isn't supported.

Log in or register to post comments