Log in or register to post comments

Unable to install Vuforia support, Unity on OSX

January 10, 2020 - 11:51am #1

Vuforia SDK Version: 8-6-7 -

Description with steps to reproduce: I just installed the latest Unity Hub, downloaded from Unity, and am following tutorial instructions to set up a Vuforia project. I'm told that in Player settings I should check "Vuforia Augmented Reality" under XR Settings. I don't have a checkbox, just a link under "XR Support Installers". That takes me to a download of UnitySetup-Vuforia-AR-Support-for-Editor-2018.4.15f1.pkg

The installer fails with the title "An error occurred during installation" and the message "The installation failed" and "The installer encountered an error that caused the installation to fail."

On older posts in the forum it says to go back and choose "Customize Installation" and select the location of the Unity editor. When I try customizing the location however, I see no editable options. Image here: https://i.imgur.com/ixmc7eV.png . The installer seems to match the installed Unity version (2018.4.15f1). -

Development OS (Mac OS X, Windows, Linux): Mac OS X -

Mobile OS and Version: Android -

Mobile Device Manufacturer and Model name: Android -

Do the Vuforia Sample Applications show the same behavior?: Not sure

Unable to install Vuforia support, Unity on OSX

January 22, 2020 - 4:58am #7

Thanks for the reply.  My question wasn't whether 8.6 is compatible with Unity 2019.2, but if 2019.2+ is a requirement.  What I found was that in Unity 2018.4.* you can add Vuforia as a module during install, and access it directly from within Unity.  Installing the package linked below, however, fails.  The package does work with Unity 2019.2+.   If a certain version of Unity is required, which may be the case here, that should probably be mentioned on the page about the package install. 

Unable to install Vuforia support, Unity on OSX

January 22, 2020 - 4:23am #6

Hi,

Yes, 8.6 is compatible with 2019.2+

Thank you.

Vuforia Engine Support

Unable to install Vuforia support, Unity on OSX

January 20, 2020 - 2:11pm #5

I was able to import the package but it fails.  Error message below.  This is the case regardless of whether I import the package via script, or manually.   I now get this error when launching any other projects.   Do I need to upgrade to Unity 2019.2? 

An error occurred while resolving packages:

  Package com.ptc.vuforia.engine@file:/Users/[username]/[Project name]/Packages/com.ptc.vuforia.engine has invalid dependencies:

    com.unity.ugui: Package [com.unity.ugui@1.0.0] cannot be found

A re-import of the project may be required to fix the issue or a manual modification of /Users/[username]/[Project name]/Packages/manifest.json file

 

Unable to install Vuforia support, Unity on OSX

January 20, 2020 - 4:34am #4

Hi,

Yes or if you want to import via Unity, Asset -> Import Package-> Custom Package (Select it from Finder)

Thank you.

Vuforia Engine Support

Unable to install Vuforia support, Unity on OSX

January 17, 2020 - 10:51am #3

From those instructions:  "The easiest way to do this is to import an editor script into your Unity project."   I'm brand new to Unity.  How do I import the script I just downloaded?  I was hoping for a little more of a step-by-step. 

Edit:  Oh, I guess I can just double-click on the script in the Finder and it runs in Unity.  

Unable to install Vuforia support, Unity on OSX

January 13, 2020 - 5:07am #2

Hi,

The new version 8.6 contains additional steps to install:

Please review below article: https://library.vuforia.com/content/vuforia-library/en/articles/Solution/vuforia-engine-package-hosting-for-unity.html

Thank you.

Vuforia Engine Support

Log in or register to post comments