Log in or register to post comments

Black flash when Vuforia is starting/resuming on iOS

March 5, 2018 - 1:34pm #1

Hi,

Each time Vuforia is starting, there is a black flash during the initialisation (less than a second).

It occurs on loading scene, or when the application is exiting background mode.

This black screen fill the entire screen, Unity UI elements are not displayed.

It is very frustrating, because this flash occurs every time notification/control centers are opened, even partially.

This only happens on scenes using Vuforia.

Here are the logs that I have when the app is resuming from background :

Quote:

DEBUG/AR(10400) UIView does not respond to selector renderFrameVuforia

DEBUG/AR(10400) UIView does not respond to selector renderFrameVuforia

DEBUG/AR(10400) Could not find a UIView with CAEAGLLayer or CAMetalLayer layer class that responds to selector renderFrameVuforia

DEBUG/AR(10400) Could not find a UIView with CAEAGLLayer or CAMetalLayer layer class that responds to selector renderFrameVuforia

StartVuforia

Vuforia.VuforiaARController:StartVuforia(Boolean)

Vuforia.VuforiaARController:OnApplicationPause(Boolean)

Am I the only one experiencing this issue, or do you have a workaround to fix it?

 

Configuration

  • Unity v2017.3.1f1
  • Vuforia v7.0.47
  • Experienced on iPhone X and iPhone 7 running iOS 11.2.6

Black flash when Vuforia is starting/resuming on iOS

April 30, 2018 - 6:21pm #5

Same Issue with iPhone 6s.

Black flash when Vuforia is starting/resuming on iOS

April 21, 2018 - 12:00am #4

I am having same issue

Let me know if you find any solution

This problem is not limited to ios but android also

Black flash when Vuforia is starting/resuming on iOS

April 10, 2018 - 3:53am #3

Try to replace Metal with OpenGLES.

Black flash when Vuforia is starting/resuming on iOS

March 7, 2018 - 4:24pm #2

I have same issue.

 

Configuration

  • Unity v2017.3.0p4
  • Vuforia v7.0.47
  • Experienced on iPhone 7 running iOS 11.2.5
Log in or register to post comments