Log in or register to post comments

Error: "Package does not contain valid import settings for:"

August 7, 2017 - 7:14am #1

After adding additional image targets to my Device Database I am getting erros when importing the unitypackage:

 

Package does not contain valid import settings for: Assets/Editor/Vuforia/ImageTargetTextures/{database-name}/{marker-name}_scaled.jpg

 

After removing the newly added markes I get the same error also.

 

Thanks

Herb

 

PS: I am un Unity 5.6.2f1 (64bit)

Error: "Package does not contain valid import settings for:"

February 13, 2019 - 8:40pm #8

Quote:

I selected all the textures

Yeah thanks, that's super informative. Which textures? 

Error: "Package does not contain valid import settings for:"

August 27, 2017 - 6:32pm #7

Update: 

I selected all the textures, clicked on the Gear for Settings on the top right corner of the Inspector window, and then clicked on Reset. Afterwards, the errors went away. Hope this helps!

 

Previously: 

I was getting the same error as they mentioned. I just updated to 2017.1 too. I was getting the same errors in the same way they are - just simply importing after downloading the dataset - no new targets for me though as it's the same dataset that was working in 5.6. I'll be checking the Unity forums too. 

Error: "Package does not contain valid import settings for:"

August 18, 2017 - 10:01pm #6

I was able to force the new package to be loaded in 5.6.3 by manually deleting the existing streaming assets and deselecting the image targets for the AR objects in the scene. 

New problem on Android - there are black polygons flashing on the screen when a target is acquired.  I am using OpenGLES2 the the graphics.  I've tried it on several different Android devices with various OS versions and they all exhibit the same behavior. It looks pretty bad.  I've stripped down the project to be just a single trigger and model.  No other plugins.  Still happens.

I tried creating a similar project from scratch.  I imported in the same model and copied in the same scripts.  It's using the same versions of Unity and Vuforia. The setup seems identical.  But this one looks just fine.  I've gone over and over the settings on the two projects but can find no difference. 

I need to find out what's going on - I cannot rebuild all my projects from scratch.  I have to be able to convert them to the new Unity/vuforia. 

Error: "Package does not contain valid import settings for:"

August 17, 2017 - 5:26pm #5

Is there a way for me to email the package to you directly?

I just tried using Unity 5.6.3.  Same errors with both the new package and the old one.  Client needs updated app within a couple of weeks.  Urgently need to fix this.

Error: "Package does not contain valid import settings for:"

August 17, 2017 - 8:45am #4

I wouldn't recommend using Unity 2017.1 as it is not an officially support version of Unity, try Unity 5.6 instead.

I have not been able to reproduce this locally, would either of you be able to provide a sample project or the dataset for me to repro it with?

Thanks,

-Vuforia Support

Error: "Package does not contain valid import settings for:"

August 16, 2017 - 6:58pm #3

I am having the same issue with Unity 2017.1.  I have an existing project where I added a new target and now I get errors when I try to import in the updated dataset.  I export it from Vuforia for Unity and then import it into Unity using assets->import package -> custom package.  I need to fix this ASAP.  I can import just fine into an empty project.  But I get the same errors with my existing project even when I try to re-import the previous package that imported fine before.  Problem was happening with Unity 5.3.6 as well - I updated to the latest Unity hoping that would fix it. 

Error: "Package does not contain valid import settings for:"

August 8, 2017 - 11:02am #2

Hello Herb,

Could you try re-downloading your dataset and re-importing it? If that doesn't resolve it, could you let me know the steps you are taking to import the dataset and try importing it into the Vuforia sample project?

Thanks,

-Vuforia Support

Log in or register to post comments