Log in or register to post comments

Skybox not working with ARCamera and ImageTarget

November 27, 2020 - 6:12am #1

Hello AR enthusiasts,

After upgrading my project from Vuforia 8.5.3 both to 9.5.4 and then 9.6.3 (current), my skybox does not show anymore when the app to an Android or UWP device. The camera preview and game tab both display the skybox correctly. This holds true for newly created projects as well.

I tried adding a skybox component to the  AR camera, setting the default skybox under Redering -> Lighting as well as setting the camera clear flags and trying out different combinations of the settings.

Unfortunately, there is still no skybox when I deploy the app (the background is the camera feed).

I am using the skybox as part of an AR app with an ImageTarget.

Thank you for your help!

Skybox not working with ARCamera and ImageTarget

December 3, 2020 - 7:35am #2

Hi,

I believe you need to de-select the option Enable Video-Background in the Vuforia Configuration file.

Thank you.

Vuforia Engine Support

Log in or register to post comments