Log in or register to post comments

Unity crashing on Play

December 19, 2018 - 2:19pm #1

Hi,

I see this topic posted several times, but I'm not sure if there is a solution. 

I have tried several computers with the same setup, and I get the exact same crash after the initial Vuforia setup in Unity.

I'm running Unity 2018.2.12f1 and Vuforia version from the Unity Installation (7.2) 

Here is the process.

  1. Activate Vuforia in my Unity project
  2. Added an AR camera
  3. Added an Image Target
  4. Click play to test,
  5. Unity crashes

Any help will be greatly appreciated :)

Below is a partial Console report...

-----------------------------------------------

Path:                  /Applications/Unity/Unity.app/Contents/MacOS/Unity

Identifier:            com.unity3d.UnityEditor5.x

Version:               Unity version 2018.2.12f1 (2018.2.12f1)

Code Type:             X86-64 (Native)

Parent Process:        ??? [1]

Responsible:           Unity [2945]

User ID:               507

Date/Time:             2018-12-19 15:30:20.620 -0600

OS Version:            Mac OS X 10.13.6 (17G65)

Report Version:        12

Anonymous UUID:        2D9E463E-C41E-A94B-2024-2E497318C5A1

 

Crashed Thread:        0  CrBrowserMain  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_CRASH (SIGABRT)

Exception Codes:       0x0000000000000000, 0x0000000000000000

Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:

*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** Can't add a nil AVCaptureInput'

abort() called

terminating with uncaught exception of type NSException

Unity crashing on Play

April 15, 2019 - 8:45am #18

Hello @abbienew,

Unfortunately, the crash log does not tell us much regarding the source of the issue.

If you can provide us with a repro project, in the form of a zipped Unity project folder, so that we can try to reproduce locally this would be the best way forward.

Thanks,

Vuforia Engine Support

 

Unity crashing on Play

April 15, 2019 - 7:15am #17

Unity doesn't show up on the Security & Privacy settings list, did you have this problem?

Unity crashing on Play

April 12, 2019 - 12:55pm #16

Hello @abbienew,

Thanks very much for the crash log. Very helpful to us.

I've escalated to the team for further review. I'll update this thread with any relevant updates.

Thanks,

Vuforia Engine Support

Unity crashing on Play

April 12, 2019 - 1:08am #15

Hi guys

I have the same problem as well. As I set an Arcamera and play it ,unity suddenly crashed.

I have tried several computers with the same setup, and I get the exact same crash after the initial Vuforia setup and play in Unity.

I'm running Unity 2018.3.6f1 and Vuforia version from the Unity Installation (8.1.7)

Here is the process.

Activate Vuforia in my Unity project

Added an AR camera

Delete main camera

Added an Image Target

Click play to test

Unity crashed

Attach is a the Console report...

Hope to find out the solution.....

thx....

AttachmentSize
Microsoft Office document icon AR_consolereport.doc239.5 KB

Unity crashing on Play

April 10, 2019 - 4:45am #14

I've been having the same problem for a while now and I was hoping it would get fixed with an OS update. But no such luck so far.

All I have to do is create a scene with a target, a Vuforia ARCamera and hit play to make Unity crash to the desktop. Every time.

Any solutions, or suspicions as to what might be the cause ? Unity already has access to my camera.

Unity 2019.1.0b7 / Vuforia v8.1.7 / Mojave 10.14.5 beta

Thanks, R.

Unity crashing on Play

April 7, 2019 - 4:48pm #13

how you change the settings I do not find it

Unity crashing on Play

March 30, 2019 - 5:28am #12

It's really work..THANKs Bro ... You saved my life...

Unity crashing on Play

March 29, 2019 - 10:46am #11

**FIX**

I came across this issue and solved it by going into my Security & Privacy settings and allowing Unity to access my camera. 

Unity crashing on Play

March 21, 2019 - 10:29am #10

Hi all,

Thanks for the reports and apologies for the inconvenience. I'll work with the team to see if we can determine what's happening.

-Vuforia Engine Support

Unity crashing on Play

March 20, 2019 - 8:01am #9

Same here. No matter what I try, can't get Vuforia to work.

Old scenes or new ones, as soon as I press play Unity crashes to the desktop.

Unity 2019.0.10b7 / Vuforia v8.1.7 / Mojave 10.14.4 beta

very frustrating...

-Ronald

Unity crashing on Play

March 11, 2019 - 9:27am #8

I have the very same issue. Unity 2018.3.5f1, Vuforia 8.0.10. Instant crash when hitting "Play" with a scene that contains 1 Directional Light, 1 AR Camera and 12 ImageTargets.

Crash log says "Can't add a nil AVCaptureInput". 

Unity crashing on Play

March 9, 2019 - 8:43am #7

We are getting same kind of crash . ALL detail are in crash log. I just added ARCamera and hit play button , unity get crash. Hope You guys have some solution for this. I am trying since Five month but no clue. Only thing I feel is after updating to Mojave OS it started.

Unity crashing on Play

January 3, 2019 - 7:30am #6

Hello,

Thanks for the response. The only crash I'm aware of is one while stopping PlayMode with Cloud reco in the scene:

https://developer.vuforia.com/forum/unity/v7520-crashes-editor

This issue is scheduled to be fixed in our next release (SDK 8.0, mid-Jan).

Is what you're seeing similar? Also, can you provide some details about your workstation setup (Mac/PC, OS version, type of camera)?

Thanks,

Vuforia Engine Support

Unity crashing on Play

January 3, 2019 - 12:07am #5

Yes unaltered. It does not work on unity 2018.3, We tried 2018.2.9f does not work as well unity just crashes

Unity crashing on Play

January 2, 2019 - 11:58am #4

Hello @Gaius,

Was this observed while running the Vuforia Core samples, unaltered?

Thanks,

Vuforia Engine Support

Unity crashing on Play

December 20, 2018 - 11:06pm #3

Hi, we faced a similar issue when trying to hit play on unity running vuforia. Please help. The attached shows the error log

AttachmentSize
Image icon error.png1.29 MB

Unity crashing on Play

December 20, 2018 - 11:45am #2

Hello,

In all our testing I don't recall seeing this issue. Nor have I seen it recently on the forums (or maybe I just overlooked it).

Do the Vuforia Core Samples exhibit the same behavior?

Thanks,

Vuforia Engine Support

Log in or register to post comments